PubMed XML Import Error

2»
  • edited December 7, 2017
    It definitely said "security update". I paid more attention than usual because of the import problem I have been having, so I am certain rather than reasonably sure. And after restart I immediately re-tried the import and was momentarily excited when it imported the smaller xml file, but it was short-lived when the larger one failed. So it definitely had an impact on the problem because the same small file, imported in the same way, failed 24 hours earlier.
  • edited 15 days ago
    On December 5 I promised an example of an XML file that seems to cause this kind of problem. It is missing the English language title but contains a vernacular title. Notice the <ArticleTitle/> tag.


    <PubmedArticle>
    <MedlineCitation Status="In-Process" Owner="NLM">
    <PMID Version="1">29292925</PMID>
    <DateRevised>
    <Year>2018</Year>
    <Month>01</Month>
    <Day>02</Day>
    </DateRevised>
    <Article PubModel="Electronic">
    <Journal>
    <ISSN IssnType="Electronic">1652-7518</ISSN>
    <JournalIssue CitedMedium="Internet">
    <Volume>114</Volume>
    <PubDate>
    <Year>2017</Year>
    <Month>Nov</Month>
    <Day>09</Day>
    </PubDate>
    </JournalIssue>
    <Title>Lakartidningen</Title>
    <ISOAbbreviation>Lakartidningen</ISOAbbreviation>
    </Journal>
    <ArticleTitle/>
    <ELocationID EIdType="pii" ValidYN="Y">EWLS</ELocationID>
    <Abstract>
    <AbstractText>Mental illness and terrorism There is little evidence supporting the concept of mental illness as a part of, or reason behind radicalization towards violent extremism and terrorism. There is weak evidence that lone gunmen, particularly those involved in school shootings, may suffer from mental illness to a larger degree than the general population, whereas organized terrorist groups such as jihadists and right-wing extremists seem to avoid mentally unstable individuals. Clinical use of the instruments developed for screening and risk assessment of individuals suspected of radicalization towards violent extremism will compromise the trust placed in the Swedish health care system by the citizens it is there to serve. The usage of empirically grounded risk assessment instruments should be restricted to forensic psychiatric clinics. Individuals at risk of radicalization towards violent extremism who present signs and symptoms of mental illness should be offered psychiatric treatment.</AbstractText>
    </Abstract>
    <AuthorList CompleteYN="Y">
    <Author ValidYN="Y">
    <LastName>Köhler</LastName>
    <ForeName>Per</ForeName>
    <Initials>P</Initials>
    <AffiliationInfo>
    <Affiliation>n/a - Vuxenpsykiatrin Malmö Malmö, Sweden n/a - Vuxenpsykiatrin Malmö Malmö, Sweden.</Affiliation>
    </AffiliationInfo>
    </Author>
    <Author ValidYN="Y">
    <LastName>Krona</LastName>
    <ForeName>Hedvig</ForeName>
    <Initials>H</Initials>
    <AffiliationInfo>
    <Affiliation>Lunds Universitet - Medicinska fakulteten Lund, Sweden Lunds Universitet - Medicinska fakulteten Lund, Sweden.</Affiliation>
    </AffiliationInfo>
    </Author>
    <Author ValidYN="Y">
    <LastName>Josefsson</LastName>
    <ForeName>Johanna</ForeName>
    <Initials>J</Initials>
    <AffiliationInfo>
    <Affiliation>Psykiatri Skåne - Vuxenpsykiatriska kliniken Malmö Malmö, Sweden Psykiatri Skåne - Vuxenpsykiatriska kliniken Malmö Malmö, Sweden.</Affiliation>
    </AffiliationInfo>
    </Author>
    </AuthorList>
    <Language>swe</Language>
    <PublicationTypeList>
    <PublicationType UI="D004740">English Abstract</PublicationType>
    <PublicationType UI="D016428">Journal Article</PublicationType>
    </PublicationTypeList>
    <VernacularTitle>Psykisk ohälsa, radikalisering och terrorism - Inget säkert samband har kunnat påvisas.</VernacularTitle>
    <ArticleDate DateType="Electronic">
    <Year>2017</Year>
    <Month>11</Month>
    <Day>09</Day>
    </ArticleDate>
    </Article>
    <MedlineJournalInfo>
    <Country>Sweden</Country>
    <MedlineTA>Lakartidningen</MedlineTA>
    <NlmUniqueID>0027707</NlmUniqueID>
    <ISSNLinking>0023-7205</ISSNLinking>
    </MedlineJournalInfo>
    </MedlineCitation>


    In a few days, the PubMed curators will probably make changes to this file as the status moves from "in-process" to either "Status="PubMed-not-MEDLINE" or Status="MEDLINE". At that point, the import likely will no longer fail.
  • thanks -- yes, I had suspected this was the case here, but it turns out it wasn't -- I wasn't able to replicate Mark's issue with the XML file that failed for him.
  • I tried it on a PC and it worked fine for me as it did for you previously. Thus it is a Mac problem. I can get around it by importing the xml file with my PC, then exporting the Zotero database as a whole and overwriting the "old" database on my Mac. (Unfortunately I have to use Mac at work, otherwise I'd just stick to PC for working with the database and just access it with Mac.)
  • and it's still failing on the Mac, yes? @dstillman you wanted to look at this I believe?
  • It's not a Mac problem — Mark's XML works for me. It's more likely that this is just a bug related to the state of the particular database.

    @Mark_SF: Are you saying that after replacing the DB with the one from the PC, additional XML files still fail on the Mac?
  • Actually, the PubMed XML import translator hasn't been updated for 5.0, so it's still using an older method that could cause problems. I suspect this is just a race condition (i.e., a problem related to the exact timing of two separate operations) and if the translator is updated this will go away. I'll try to do that soon.
Sign In or Register to comment.