Exporting folder with no data but with "sub-folders" in it that does include data

Hi there, I really need your help as I am using Zotero for my job at a Danish university.

After the recent update I cannot export folders with no data but with "sub-folders" in it that does include data.

The folders would look like this: Communications (emtpy) -> 7th semester (empty) -> Media Aesthetics (lots of data in it)

I can only export the Media Aesthetics folder but I need it to be in that exact order, inside the two other folders. Can anyone help me?

Thanks a lot
  • Export to what?
  • export to a file, like bibtex or RDF
  • It would be helpful to reply with the purpose of your desire to export the structure of your collections and sub-collections. There may be a way at accomplish what you want. Are you trying to export part of a Zotero library to be imported into a Zotero program being used on a different computer? Are you seeking to format a print or pdf report that is organized with headings and subheadings like your collection/sub-collection structure? Some other purpose?

    Zotero collections are not identical to computer file system directories, although both use a file folder icon. Zotero items can be in multiple collections much like a song can be in multiple playlists. All Zotero records are in your Zotero library and your library can be organized into collections. Unless you have duplicate records (generally a very bad thing); any single Zotero record can appear in multiple collections without the item being a duplicate.
  • Hi there
    I am trying to export part of a Zotero library to be imported into a Zotero program being used on a different computer. I create collections or as I call them, folders, with data/references for specific bachelors and masters at the university I work at. Its quite important zotero can show it in the right way, with the first two empty folders and then the folder containing data. If not, the students won't know which data belongs to which semester ect.
    I need to export my collection/folder to RDF files for example, so I and send them to the student and they can open them on their own computer
  • The easiest way to do something like this would be to set up a Zotero Group shared between you and the student. Then, they can just drag the items from the group to their own library.
  • Sadly I can't do that. We are talking over 1000 students and I don't know they personally
  • Can you do this as a public Zotero Group?
  • No that is sadly not possible, im required to export files.
  • edited November 29, 2017
    Okay, I did some exploring. There are two ways to get close to what you want.

    First, enable the "Recursive collections" hidden preference: https://www.zotero.org/support/collections_and_tags#recursive_collections. This will show all of the subcollection items in the top-level collection. You can then export the collection by right-clicking.

    Alternatively you can place a placeholder item in the empty top-level collection, then export by right-clicking.

    For either method, when you import, all of the empty subcollections will be maintained as desired. However, all of the items will be added to the top-level collection. From what I can tell, this is a limitation of all of the available export formats--they just don't represent an empty top-level collection in this way. You can instruct your students to either just ignore the top-level collection or to select all of the items in it, right click, and choose "Remove items from collection".

  • The first option might work, I'll try exporting tomorrow :) So far, thanks a lot!
  • (I edited my post while you were posting. Be sure that you are aware that all of the items will be added to the top-level collection. There unfortunately isn't a way around that with export/import.)
  • I'll try adding a placeholder :)
  • That does seem like a bug to me, though. I see no reason this shouldn't be possible.
  • @adamsmith yeah it was possible before the update :(
  • I have the same problem. Has this been added to the bug tracker? According to the previous comments this seems to be a regression. Any chance of having a developer taking a look a this issue?
  • The developers read every thread on the forums. This is the best place to report.
  • @bwiernik Thank you for the feedback. I hope this is an interesting challenge for someone who has the skills to fix it (unfortunately I don't...)
  • This is fixed in Zotero 5.0.45, available now via Help → Check for Updates.
  • edited April 26, 2018
    @dstillman I just had the time to test this now. Unfortunately it is still not fixed... I exported a Collection which includes 5 Subcollections. There are no references at the top level and 3 out of the 5 Subcollections include the same reference. After exporting to Zotero RDF and importing again, the new collection is correct except that it the reference is showing also at the top level. Maybe I should not be using Zotero RDF?
  • The thing I fixed is the problem reported by the OP: the export option being disabled when there were no direct child items of the collection, even when there were subcollections with items.

    Items in subcollections being added to the top collection is a separate issue, and someone would have to look into whether that's possible to fix in the available export formats. But as bwiernik says above, you can simply remove the items from the top collection after the import.
  • @dstillman Should I open a new thread then? I understand the workaround but I really wanted to send a clean example to people with reduced computer literacy which I'm trying to motivate to use Zotero. I will test this issue with several formats in other reference managers to try to find a valid candidate. Thanks!
  • No need for a new thread — I've created an issue to track it.
  • I will post my findings on Github then. Thank you again!
  • There's really no other information needed. Standard bibliographic exchange formats don't include the concept of collections. Someone will just need to look into whether we can fix this with the Zotero RDF.
Sign In or Register to comment.