LibreOffice plugin: No italics in CMS footnotes

edited November 26, 2017
CMS footnotes do not have italics on titles and journal names.

* OSX 10.10.5
* LibreOffice Version:
* Zotero Standalone: 5.0.28
* Chicago Manual of Style 17th Edition (note)

I've reinstalled LibreOffice, reinstalled the office integration plugin, updated JDK. My old papers from last spring all have italics in inserted footnotes. But when I open those papers and insert a new footnote, book titles and journal titles in the new footnote do not have italics. I know that the troubleshooting documentation says that LibreOffice controls the formatting, and it's true that you can change the overall spacing, font size, and font style etc for a footnote in LibreOffice, there doesn't seem to be any way to change the formatting of just one part of a footnote.

I've also checked out the Zotero style editor and preview and the italics appear correctly there.

  • How about in a new document?
  • Same thing in new documents.
  • I'm a bit confused when journal names would ever show up in Chicago (note) footnotes. Have you tested some other footnote styles like Chicago (full note) or MHRA? What are some example footnotes?
  • edited November 26, 2017
    Sure, journal titles don't show up with the note format. But they do with the full note format, and they aren't in italics. MHRA, same thing. No italics.

    Here's an example copied from a footnote in my project. In this case "Tendencies" is the book title and should be in italics:

    Sedgwick, Tendencies, 25.

    You can download the RIS here:
  • (Just in case that wasn't clear -- the styles still have italics in them and those show for me). Are you using the classic add citation dialog (the one that shows all your collections) or the regular one (with the red frame)? Does that make a difference?
  • edited November 26, 2017
    Just tried with the classic dialog: it doesn't seem to make a difference. (Thanks for you help, BTW. Really appreciate it.)
  • Sorry about this. It is a Zotero bug. We have a fix in the Beta release. You can install it if this is urgent or wait for the fix to be released in the next proper update.
  • Good to know! Will have a look at the beta. Thank you.
  • edited November 27, 2017
    Anyone else who runs into this:

    1. Install the beta release of Zotero
    2. With LibreOffice closed, reinstall the LibreOffice integration plugin in the Zotero preferences
    3. Open the LibreOffice document, open the Zotero document preferences, and re-select the formatting of choice
    4. Citations and footnotes will be reformatted when this dialog closes, with italics in book and journal titles where appropriate
  • It looks like using the dialog to insert footnotes still doesn't result in italics. I have to open the "Set Document Preferences" dialog and save without making any changes. The entire document is reformatted and italics are added to the footnotes that need them. I'll file a bug report. Thanks for the help.
  • I'm seeing italics when inserting a footnote citation. Does it work in a new document?
  • It is the same in new documents.
  • What if you reinstall the release version of Zotero 5.0.29, reinstall LibreOffice plugin in Zotero preferences and try again?
  • Fixed with Zotero 5.0.29.
Sign In or Register to comment.