Zotero connector malfunctioning

When I am using the zotero standalone and connector with through my university library, I only get the connector as an active link sometimes. The connector icon shows as a page with a blue line for a webpage, and a page with lines for a journal article. However, many times it only shows as a page with a grey line, even if I am on the library page for a journal article.

I wish I had better words to describe that. :) If I refresh the page, sometimes that is enough to trigger the change from grey icon to journal icon. Sometimes it takes going back to the search list, and then going back into the article. If it play around enough, I can get the connector to trigger and recognize the journal article.

This behavior is new within the last several weeks. I did not have that issue prior. I am running Chrome Version 62.0.3202.94 (Official Build) (64-bit); on Windows 10 (also updated). My adblocker is turned off for all university sites, but I am using uBlock origin.

Is anyone else having this issue? Is there a fix? Thank you!
  • What are some URLs for pages showing only the gray page icon m?
  • For example, this link gives me a grey icon:

    However, a refresh (F5) of the page toggled the correct icon, and I can save it.

    This link: https://web-b-ebscohost-com.unr.idm.oclc.org/ehost/detail/detail?vid=4&sid=089b53a4-0e7c-4fc8-a0ef-4c3f0d180754@pdc-v-sessmgr01&bdata=JnNpdGU9ZWhvc3QtbGl2ZSZzY29wZT1zaXRl#AN=EJ1078456&db=eric did the same thing. Grey icon first.

    A refresh also toggled the icon. However yesterday, I had several links (same search, just different links) that did not toggle. I figured out that if I changed the language to something else, then back to English, then hit the back button, it would toggle.

    This discovery was completely by accident, but it worked when the refresh alone did not work.
  • If you can replicate the sequence of non-loadings, a Debug ID or several for the various loading steps (to the gray page, then reloading to the proper icon) would probably be helpful.
  • The Debug ID is D2016463559

    I have the debug output saved as well. I didn't post it all here. It is long. If you would like it, I can provide it.

    This debug code was for the language change, change back, and back method of toggling the connector. A refresh did not toggle the icon in this case.

    Thank you very much for your help with this.

  • The Debug ID will let the Zotero developers see the full text of the log. I can’t see them, but they will post here if they have additional questions or updates.
  • @gwaddell Sorry it took a while to respond. Could you produce two debug IDs (and post them here):

    1. From a search page navigate to an article; connector icon displays an article icon and when hovered over says Save to Zotero (EBSCOhost)
    2. From a search page navigate to an article; connector icon remains grey; refresh the page and the connector icon displays an article icon and when hovered over says Save to Zotero (EBSCOhost)
  • Hello,
    Apologies for the delay. It was a rough week!

    This is the Debug code for the greyed out icon. I am on the EbscoHost website, a journal article is open, however it says, "Save to Zotero (webpage with snapshot)" when I hover over the icon. When I click it, it saves nothing.

    1. D803603280

    Next, I hit "clear output" to get the next code. I also changed the Ebsco language from English to German, and back to English, then hit the 'back' button. The icon changed from grey single bar, to white with lines.

    2. D694839923

    Changing the language sometimes is enough to trigger the icon change from grey bar, to white lines (webpage not able to be saved, to journal article). this is a different article, first showing grey, then changing the language ONLY 1 time, not two.

    1. D1258498490
    2. D1305940006

    I hope this helps you track down the issue. I can live without any other extensions, but I have to play this game, now, every time I add an EbscoHost article to my library.

    Thank you!
  • Code could not be retrieved
    You're getting some weird errors in there. Is this with all other extensions disabled?
  • edited December 4, 2017
    Actually, I don't think that error is related (or a problem). But do confirm that you've tried with all other extensions disabled — EBSCO is working fine for me.
  • If you haven't yet, you should also try resetting translators from the Advanced pane of the preferences in both Zotero and the Zotero Connector. (Basically, you want to try everything on Troubleshooting Translator Errors.)
  • Zotero Connector 5.0.29 is out which should fix the problem.
Sign In or Register to comment.