Very slow startup

This discussion was created from comments split from: Opening Zotero -it takes more than 50 minutes-.
  • I found this thread while searching the forums for a solution to a similar problem that I've been having with Zotero Standalone's very slow loading times. I too have a large library (20,000+ items, 2.3GB sqlite), and the slow loads are most evident on my older computer (mid-2009 MBP, running El Capitan). My newer computer (2016 MBP), which syncs with the same Zotero library, runs somewhat faster. Unlike PaulVG, I don't have any embedded images in notes. But I do have many website snapshots and PDFs saved from JSTOR, et al.

    Regardless, I'm sure that several hours of loading time is not normal. So I wonder if something's wrong with my database. For the past two hours I've been running "Check Database Integrity," but it doesn't seem to have finished.

    Instead of waiting any longer, I thought that I'd post a Debug ID to see if people have any thoughts. Here it is: D206229552. Thanks in advance!
  • edited November 22, 2017
    Splitting this off since the cause will be different.

    Does this happen if you disable temporarily full-text syncing in the sync pane of the Zotero preferences, and if so can I see a Debug ID from startup for that? (No need to run "Check Database Integrity" — with a multi-GB database, that SQLite command may just be extremely slow.)
  • Thanks for the reply. I'll try disabling the full-text sync and generating another Debug ID once I get back to the office computer next week after the holiday. My home computer is the newer/faster one, and I don't have the same speed issues here. So, please stay tuned . . .
  • Okay, back in the office. I disabled full-text syncing and restarted Zotero. It still takes a while to load, but it does seem somewhat faster. Here's the Debug ID: D1251419543
Sign In or Register to comment.