Zotero Connector not working

2»
  • This problem is both on my laptop and on my desktop computer. I have tried different wifi-connections too.
  • Ok, could you submit a Debug ID from Chrome and Firefox for this procedure:

    1. Enable debug logging (by checking the checkbox)
    2. Open a new tab and navigate to https://www.reuters.com/article/us-libya-security/u-n-condemns-civilian-deaths-from-air-attack-in-east-libya-idUSKBN1CZ2NM
    3. Wait for the page to load fully
    4. Switch back to Zotero Preferences tab, disable debug logging and submit the Debug ID
  • Alright, done.
    For Chrome, the debug ID is: D452718390.
    For Firefox, the debug ID is: D2074704400.

    Thank you so much for helping me.
  • edited December 4, 2017
    Looks like something outside of the browser, like security software, is preventing the extension from functioning properly, which is why it doesn't work for either browser. What do you use for security software and are you able to temporarily uninstall it or at least disable and restart the computer with it still disabled?
  • I just uninstalled the AVG antivirus program and restarted the computer, but it's still the same.
  • Hmm. Is this a very slow machine? Are you on a slow internet connection?
  • No, my desktop computer is relatively new actually, I bought it new 3 months ago. Internet is not slow either. Everything was working perfectly fine up to about 3 weeks ago.
  • edited December 5, 2017
    Could you remove the Connector from Firefox, install the version 5.0.24 (released in late September), then navigate to about:addons click "More" for Zotero Connector, select Off for Automatic Updates, then submit a Debug ID using the previous instructions and report whether it works?
  • Apologies for late reply. I have now done what you said, and the Debug ID is: D1946320428
  • It is working!! Thank you so much for your help, I'm beyond grateful!
  • The Debug ID is empty. Make sure you don't click "Clear Output" before "Submit Debug Report". Please follow the instructions in this comment
  • Just a word here to say that I had the same issue, with the last version of Firefox, Zotero and Zotero connector, and that the solution of installing an older version of Zotero connector (via the link provided by adomasven) worked immediatly.
    I deactivated the auto-update of the plug-in, but will try a new version from time to time, to see if the problem is solved.

    Thanks a lot
  • I have the same problem as described by several above. On Mac Pro and Google Chrome. The button works here at this page and Dontprint´s instructuion webpage. I do also have very much the same problem with the Dontprint exstention on Chrome.
  • For problems saving, see Troubleshooting Translator Errors.

    Note that there's a new version of the Zotero Connector available, 5.0.32, that may improve its reliability for people who were having trouble.
  • Nor on Chrome indeed. Can no longer save to zotero and frankly beginning to wonder whether all the steps above are worth it - it 's supposed to work for us, right???
  • This thread is 10 month old and almost certainly not relevant to whatever issue you're facing. Run through https://www.zotero.org/support/troubleshooting_translator_issues and start a new discussion with the information from the last step if the other ones don't fix your issue.
Sign In or Register to comment.