Zotero 5 does not start after installation

edited November 16, 2017
With firefox 57, my zotero automatically updated to the connector only version.

I thus installed zotero 5 to access again my library. I downloaded the tarball and launch the zotero.jar file.

Zotero starts correctly the first time but I cannot open it a second time.

Zotero is now in my applications list but when I tried to launch it from terminal I've got:

$ zotero
xulrunner not found, trying firefox instead.

After a while, I figure out that zotero-standalone debian package was installed. I deleted it and tried to reinstall zotero 5 from the tarball. The executable does not launch anymore now.

Any idea ?
  • 'zotero.jar'? Do you mean 'zotero'?

    Does it work if you redownload and extract the tarball and run it again?
  • edited November 16, 2017
    Well, except you're running 'zotero', not './zotero'. So if that's not working, that sounds like a problem with how you've set it up in your path. The tarball includes a Ubuntu desktop file, so if you're on Ubuntu you should be able to symlink that to the appropriate location, as explained in the installation instructions, and open Zotero via your launcher, but beyond that you're on your own for configuring it.
  • Thank for the answer.

    I updated my question. I believe the problem was caused by the presence of zotero standalone outdated (4) debian package on my system.

    But now nothing happens at all when I launch zotero from the extracted tarball. I tried to download it again but same problem.
  • What do you mean by "nothing happens"? Are you running ./zotero?
  • Yes but running ./zotero is just a way to launch the bash file "zotero". I tried also "sh zotero".
  • './command' and 'command' are generally not the same on Linux system — that's why you were accidentally running the older 'zotero' package elsewhere in your path before. I'm just clarifying that you're now actually running the script from the tarball and not still trying to just run 'zotero' from the terminal.

    If ./zotero isn't working, you'd have to say what exactly is happening.

    You can also try ./zotero -ZoteroDebug to see if a debug window pops up (or ./zotero -ZoteroDebugText to output it to the terminal).
  • The first (only) time zotero 5 started, it prompts me for installing libreoffice integration. There was no button to say no so I did it (even if I don't use libreoffice). After it never start again.

    I will try to purge my zotero profile.
  • That shouldn't be necessary. Just run it with debug output.
  • There was no button to say no so I did it (even if I don't use libreoffice).
    (There's a Cancel button in that dialog.)
  • Running with debug option does not add informations:

    $ cd bin/Zotero_linux-x86_64/
    pprw@punda:Zotero_linux-x86_64$ ls
    application.ini fonts libmozavcodec.so libnssdbm3.chk libssl3.so updater
    chrome gmp-clearkey libmozavutil.so libnssdbm3.so libxul.so updater.ini
    chrome.manifest gtk2 libmozgtk.so libnssutil3.so minidump-analyzer zotero
    components icons libmozsandbox.so libplc4.so omni.ja zotero-bin
    defaults icudt58l.dat libmozsqlite3.so libplds4.so platform.ini zotero.desktop
    dependentlibs.list libfreeblpriv3.chk libnspr4.so libsmime3.so plugin-container zotero.jar
    dictionaries libfreeblpriv3.so libnss3.so libsoftokn3.chk set_launcher_icon
    extensions liblgpllibs.so libnssckbi.so libsoftokn3.so Throbber-small.gif
    pprw@punda:Zotero_linux-x86_64$ ./zotero
    pprw@punda:Zotero_linux-x86_64$ ./zotero -ZoteroDebug
  • What about -ZoteroDebugText?
  • I was afraid to cancel the all installation process with this button (it is unclear it cancels only libreoffice integration or the zotero 5 startup/installation).
  • Nothing either for "$ ./zotero -ZoteroDebugText"
  • Maybe I have a dependencies missing? I am running debian unstable.
  • it is unclear it cancels only libreoffice integration or the zotero 5 startup/installation
    Fair enough. We should probably change it to "Skip".
    Nothing either for "$ ./zotero -ZoteroDebugText"
    How long have you let it run? (Not that it should take more than a few seconds.)

    You can try purging your Zotero profile directory and the profiles.ini file, though I wouldn't expect different behavior.

    Running it with strace -f might tell you something, since it seems like it might be hanging on some sort of I/O.
  • "$ ./zotero -ZoteroDebugText" doesn't hang. I don't kill it, it just last less than 1s.

    I launched strace. The result is here: https://paste.aperture-sc.net/?826c338448a5a40f#6z2OQsCLOWzeovEYJHhVOtuQVHRj9CLGy7OIAnKF27o=
  • Ok It fixes. I rebooted my computer.

    It seems you need to reboot the computer after uninstalling zotero standalone 4 in order to be able to launch zotero 5...

    Sorry for for the trouble.
  • However the zotero.desktop file doesn't seem to work on Debian (no Zotero in apps, start only from the commandline)
Sign In or Register to comment.