Where can I find my configs of the vanished Firefox Zotero Plugin?

Totally surprised and hit hard by the Zotero-Firefox-Addon-disappearance today I have installed the standalone Zotero 5.X program. My Zotero data are/were not stored in the Firefox or Zotero directory but on another partition from where they are synced to my private WEBDAV cloud and from there to all my other computers when they are turned on. Unfortunately the FAQs don't give any hint what to do when the Zotero data directory is located elsewhere. When opening Zotero standalone, there was no option to search for old config or paths to my data etc. What should I do? Is there any danger of losing all my data and the database when trying to enter the access data in Zotero standalone and making a mistake?
  • Generally just pointing Standalone to the data directory is all you need to do. You should always have a back-up copy of your data directory (as of all important data), but it's unlikely it'll break.

    Without fully understanding your set-up, I will note that using any sync service other than Zotero to sync your database (as opposed to your files) across devices isn't supported and is prone to data corruption and data loss.
  • Thanks for your reply!

    At least this is the last coffin nail to my many years lasting liaison with Firefox which has been crashing and performing suboptimally for quite a while now.

    Maybe I miscited - I do not synchronize the database, only the attachment files, which are a lot. When I started out with Zotero years ago, I also tried the standalone program with different attachment file sync target. Now this target is appearing in the standalone which I have only updated. I will uninstall the standalone and install again and configure. I have regular backups of everything. I was afraid I might corrupt irreversibly the database on the Zoteroserver.

    Did I miss anything in the months before? Am I the only user who is completely baffled one beautiful day by the disappearance of a working extension?
  • you can't corrupt the database on the server, so no worries there.
  • fine!

    I have uninstalled the old standalone including personal data and reinstalled the 5.x version downloaded today. When I start it the first time, I still get a collection of entries though I expected a clean table. When going to Edit-Preferences-Settings-FileSyncing and enter the address etc of my webdav server, try to verify, I get the error message " Please enter a WebDAV URL". The address is definitely correct and the same which has worked for years and is still entered without problem in the Firefox extension in one of my laptops, which I have started now without internet access to retrieve the config data.

    How can I get rid of old config data of the old standalone try?
  • Maybe I have encountered the solution now:
    After entering the Advanced-Files&Folders directory locations and restarting, I entered the WEBDAV-URL again and now it was accepted.
  • Zotero 5.0 generally would pick up a custom data directory automatically, but it sounds like you might have had a separate Zotero profile directory (from trying Zotero Standalone previously) that also had an old data directory. You should just point Zotero to your existing data directory from the Advanced → Files and Folders pane of the Zotero preferences — you don't want to sync to pull everything down.

    You can then delete the old 'zotero' directory (with zotero.sqlite, etc.) in your Zotero profile directory.

    We can debug the WebDAV issue once you're up and running with your old data directory. (I think there's a bug where you might have to tab out of the password field first on some systems.)
  • Great relief! Worst case scenario did not happen....
    Being an informed optimist, everything pretends at least to be running and up.
    Yes, I found a Zotero profile directory on my system/program drive C: with a zotero.sqlite file also from today but the correct much bigger one in my data drive D: zotero directory, where also the attachments are stored. Syncing works.
    Thank you very much for your patience and support!
Sign In or Register to comment.