connaitre les fichiers non indexés

Existe-il un moyen d'avoir une liste des fichiers pdf associés aux notices, uniquement ceux qui ne sont pas indexés ?
Cordialement, Gérald GRUHN
  • edited November 15, 2017
    Currently, no. There is an AutoIndex plugin that keeps the index up to date in the background ( Note that it's not yet compatible with Zotero 5.
  • For PDFs, doing and advanced search with
    Attachment File Type --> is --> PDF
    Attachem Content -- does not contain -- .

    (using the little arrow next to the text field to set it to regexp) actually should pretty much find you all non-indexed PDFs.
  • J'ai la version 5, je ne peux utiliser le plugin.
    J'ai testé le méthode adamsmith, mais j'ai provoqué un bug de Zotero (avec rapport d'erreur envoyé). Faut-il demander le "contenu des pièces jointe" vide, ou un point (a dot) ?
    Je peux voir la petite flèche dans le champ texte, mais si je clique dessus, il ne se passe rien, aucun menu ne s'ouvre. Peux-tu un soucis de configuration ?
  • It should be a dot, but of course you shouldn't get an error. Which version of Zotero exactly are you running?
  • No sory, I have the, not the 5 one. Perhaps I have to upgrade ?
  • Yes, I'd recommend that.
  • I check the database, no problem
    Then I restart, using a dot. Zotero works for a minute (11000 files in my database) and return with no result. I'm sure about 400 pdf file image are in my base (the one I try get the name), so the result seems incorect.
  • precision : I run the tool from my library, the root one
  • The bug continues. So I will upgrade. Thanks. GG
  • With the upgarde to 5, the problem stil exist but is different. If i run one time the double edge request you recommand, the window is blank (nothing more is written, than the welcome page of searching), but I keep the hand, Zotero does not failcompletly, but impossible to work. I must stop software and run it again. So the bug change but still remains.
    I can do the search with only pdf attached files, non problem. But if I added the contents one, fail. however, I cannot develop the menu under the little arrow in the text field.
    An idea ?
    All the best. GG
  • So just that I understand correctly -- you have "Attachment content" (or rather, its French equivalent) -- is not -- selected and then when you click on the little arrow at the left of the text field there are no options?

    @dstillman any ideas? Maybe a localization issue?
  • If I use the content filed first (without type of file), I have a menu with 4 options under the arrow
  • oh interesting - so if you set that to regexp and put a . in the field, does that work?
  • sorry read : "the field" not "the filed" !
  • If I run only the search with content do not contains dot, I have a result. But impossible to work any more, I can save the search, in this case the search will be empty, and the same if try to open any collection. The only solution is to stop Zotero. And to suppress the result of search collection, unless i cannot access no items at all !!!
  • If I use the type of file first, and the content search second, impossible to have the menu under the arrow. Only possible if I use the context search first, and then the bug described. Nothing more is possible, Zoetro is down...
This discussion has been closed.