database disk image is malformed

Hey there, I get the following error message under Zotero 5 in Ubuntu:

Es gab einen Fehler beim Start von Zotero.

Error: Error(s) encountered during statement execution: database disk image is malformed [QUERY: SELECT COALESCE(MAX(valueID) + 1, 1) FROM itemDataValues] [PARAMS: ] [ERROR: database disk image is malformed]
From previous event:

Can anybody help? Thanks in advance!
  • I just got the same error after restarting my zotero under windows :(
  • Is this the same exact database (rather than a synced version, say) accessed in a dual boot set-up?
  • thanks for the quick reply! it might actually be a common webdav-database, yes.
  • hmm -- I don't quite understand that answer, but you can try this:
    You also likely will want to re-think how you set up your data directory -- it's pretty tricky to have that working well with the same data directory accessible from linux and Windows on a dual boot.
  • I used to run a similar setup with Mac/Windows. I got constant database corruption like this. It really doesn’t work well to try to access the same database file with a dual boot or virtual machine.
  • One of us tried this with Parallels and suffered database corruption when trying to use a single database across both OSs.
  • The dbfix worked, thanks a lot!
    indeed I was using a virtual machine. In fact I could have recovered most of my database from a different computer otherwise.
  • just a little note for those who might encounter the same problem: the repaired database may contain gaps that are not detected by syncing.

    in case you (recently) synced your library with the zotero server, you can simply close Zotero and move 'zotero.sqlite' and 'storage' from the Zotero data directory to somewhere safe, and then sync. This will download the last edition of your library and the world is in order again. Good luck!
Sign In or Register to comment.