"Save to Zotero" not functioning properly with Factiva


I utilize the Zotero Connector "Save to Zotero" bulk download feature regularly in Factiva (where the little connector icon turns into a folder and I can select source docs from a list, which are updated to my library).

It has been working fine for months, but since this weekend it only gives the "webpage with a snapshot" option/icon in the top right of the browser.

I'm using Chrome, but I downloaded firefox and checked with the extension there as well but not working there either.

Any ideas would be appreciated. I have become reliant on this feature for my workflow.

Many thanks,
  • Can you provide an example URL that's not saving? (You can x out any identifying info.)
  • Thank you for replying. Here is the url after a factiva search:


    Sorry, I don't know if "suid" has any identifying info, so I blocked that part out.
  • (it doesn't; that's the session ID -- the part that Dan was referring to was your university name, which is still in the URL, but I assume you don't mind)
  • Could you, under chrome://extensions/, check that you have Zotero connector version 5.0.26 -- the update from 5.0.25 may have fixed something related.

    (Factiva still works for me on campus, but haven't had a chance to test remotely)
  • edited November 7, 2017
    Okay thanks.
    I checked and I am on 5.0.26 so unfortunately that is not the problem.
    I'm remote, but can't check on campus. Thanks for your work.
  • @adamsmith were you able to test it remotely?
    I'm wondering if it is a global problem or just my problem.
    I tried uninstalling and reinstalling the connector, but that didn't work.
  • Not an issue for me using Chrome on Windows with a proxy that should work exactly like the one at McMaster.

    Could you say exactly what you're doing (including specific search strings, any subset of publications you select etc.? Unfortunately URLs won't work here since Factiva works with a session ID exclusively.
  • I searched for NAFTA, in the past week, in the Source: Inside US Trade.

    Normally such a search result would cause the little "save to zotero" icon in chrome to change to a yellow folder, at which point and would click and check off the stories I would like to save to zotero.

    Alternatively, if I were to open a specific headline, the "save to zotero" icon would become a little newspaper (iirc) and save just that story.

    Neither of these options are working. I only get "save to zotero: webpage with snapshot"

    I will try uninstalling and reinstalling zotero. maybe that will change something...
  • If other sites are still working, save yourself the trouble of re-installing. This is likely very specific -- Factiva is a messy site, so small things may be breaking this, which is why I was asking about details.
  • Okay thanks for replying.

    Yes, google scholar works fine with the folder icon so I'll take your advice. I have noticed in the past that sometimes the folder icon doesn't "catch" on the first search attempt, and I have to close the browser and rerun the search.

    Difference this time is that it wont catch after multiple attempts. Just remains on the "Save to zotero: webpage with snapshot"
  • Okay, some further details.

    It seems to be working on chrome on my wife's mac, so must be connected to windows?
  • No, I have this working on Windows -- do you have any extensions/add-ons installed in your browser(s)? Could you try de-installing?
  • Okay, I de-installed/re-installed.

    The save to zotero now is working on firefox, but still not chrome. I suppose this will have to do for now. Thanks for having a look.

    Now the problem is that when printing reports from the report generator the font is incredibly tiny. but i'll make another post for that.
  • Any updates on this issue? I have the same problem here (Zotero connector with Chrome not working on Factiva). It was working fine a couple months ago.

  • I am also unable to save a Factiva article to Zotero using the Zotero connector on either Firefox or Chrome. I did not have this problem until I upgraded to the new version of Zotero (5). I have uninstalled and reinstalled the connector from both browsers and even reinstalled Firefox but still have the same issue.
  • Hi Sue, no update from me. My chrome still doesn't work. I uninstalled everything and reinstalled to the newest firefox and it started working again on firefox.

    No idea what the problem was or what fixed it.
  • Hi,

    Is it possible to wipe off the Zotero connector memory from Firefox completely? Seems like even after uninstalling and reinstalling Firefox remembers the bookmarks and plugins..Is it a Firefox issue or Zotero issue?

    On the other hand, Safari is working fine saving from Factiva.

    Thanks for any feedback.
  • To the degree you haven't already, make sure you try with all other add-ons disabled.
Sign In or Register to comment.