How to create a modified version of a style and keep the original

I'd like to make a copy of a style, modify it, and keep both the original and modified style in the Style Manager.

First, I tried editing the style for Modern Language Association using the Style Editor in the Cite tab of Preferences. I changed the element to "Modern Language Association 8th edition -Temp" and saved as modern-language-association-temp.csl, but this new modified style displaced the old one entirely in the Style Editor. Fortunately, I was able to recover the earlier state.

Next I tried copying the .csl file in the styles folder, editing it outside Zotero with a text editor and changing its name as above. When I then double-clicked on it to install the style, I got the following message: "Update existing style "Modern Language Association 8th edition" with "Modern Language Association 8th edition - Temp" from (null)?" This didn't look promising, so I cancelled.

Is there a way to accomplish what I'm after?

I want to have access to the standard version of MLA but also be able to work with a modified version that meets the idiosyncratic variations of particular journals.
  • Instructions are here:
    Key part is to change the id in the style.
  • Thanks, that worked, and, yes, my not changing the id was the main issue.

    I have managed to make the few modifications to the MLA 8th edition that I need at the moment with only a rudimentary knowledge of csl. The one thing I wasn't able to address was the missing space between an initial and a full first name. A full first name followed by an initial is fine.


    Jones, Andy B., and A.Ben Smith.

    Or, switching the order of the two authors:

    Smith, A.Ben, and Andy B. Jones.

    I made sure to include the space in the First Name field.

    Is there a simple csl tweak to fix this? If you are able to tweak the base MLA csl, could you perhaps indicate what code you changed, so that I don't have to recreate my modified style from scratch?
  • Are you sure you don't have the author as A.Ben Smith in Zotero? CSL doesn't understand that's a name and an initial. It is able to toggle between A Ben Smith and A. Ben Smith (with MLA producing the latter)
  • Here's a screenshot of my entry: space between abbreviations and names.png?dl=0

    Note that I do have a space between A. and Ben.

    Are you unable to reproduce the issue?

    Here are some of the bibliographic entries from a sampling of styles. Note that Cell puts no spaces between initials, as is common among scientific formats. MLA's authors should be like the American Anthropological Association, but they aren't coming out that way.

    American Anthropological Association:

    Smith, A. Ben, and Andy B. J. Jones
    Test. Written Communication 7(2): 200–31.

    American Psychological Association 6th edition:

    Smith, A. B., & Jones, A. B. J. (1990). Test. Written Communication, 7(2), 200–31.


    Smith, A.B., and Jones, A.B.J. (1990). Test. Written Communication 7, 200–231.

    Modern Language Association 8th edition:

    Smith, A.Ben, and Andy B. J. Jones. “Test.” Written Communication, vol. 7, no. 2, 1990, pp. 200–31, doi:10.1177/0741088390007002002.
  • Weird, yes, seeing this too. You can get this right by changing initialize-with=". " to initialize-with="." that's a bug -- it should be the other way around if anything -- but it'll work.
  • That workaround appears to introduce one new problem as it solves an old one. Now two initials side by side no longer have a space between them, where they did before.

    Smith, A. Ben, and Andy B.J. Jones. “Test.” Written Communication, vol. 7, no. 2, 1990, pp. 200–31, doi:10.1177/0741088390007002002.

    I guess this would need to be debugged, presumably by the people who oversee csl?
  • the processor, specifically, not the styles. @fbennett
  • Right, that is what I thought. Thanks for escalating, which is what I assume you just did?
  • Thanks for all this checking, everyone. The bug should be fixed in the latest Propachi plugins, and at processor release tag 1.1.180.
  • Thanks very much. I will wait for the next Zotero update or download the plugin if I need this working before the update.

    I just came across another glitch that may have to do with processor code rather than the csl. When there is both an editor and a translator in MLA, the "translated by" is capitalized even though it appears in the middle of a sentence, as below:

    Fleck, Ludwik. Genesis and Development of a Scientific Fact. Edited by Thaddeus J. Trenn and Robert K. Merton, Translated by Fred Bradley and Thaddeus J. Trenn, University of Chicago P, 1979.
  • The latest 5.0 Beta is available with citeproc-js 1.1.180.
  • I've had this work for me in the past, but now when I try to load the modified style under Zotero Preferences I get:
    Unexpected error occurred while installing "C:\... .csl"
  • Make sure that your style validates:
Sign In or Register to comment.