Quick copy keyboard shortcut not working

I have selected Bibtex as the default quick copy. When I copy through the menu Edit -> Copy as BibTex, it works fine. But when I try to use the keyboard shortcut (Cmd + Shit + C on a Mac), nothing gets copied.
  • does drag&drop work?
  • @adamsmith Yes, drag&drop works fine.
  • hmm -- we could try if a debug ID for selecting an item and then pressing cmd+shift+c tells us anything:
  • Does it work on your end?
  • debug ID: D1137812411
  • yes, but I'm not on a Mac. Dan is, though, so if this is a general issue, he'll be able to replicate.
  • Command+C works for me. I’ve used it several times in the last hour. The content goes to clipboard and may be imported to Zotero. I didn’t incorporate the shift key and I haven’t yet upgraded to the most recent Mac OS version (High Sierra).
  • Cmd + C doesn't do anything on my end. In fact the corresponding menu entry under Edit is disabled. I only have Copy as Bibtex enabled, and the shortcut listd is CMD + Shift + C.

    Still not working here. I am using macOS High Sierra 10.12.6
  • I’m trying to be helpful and not be a pedant. OS 10.12.6 is Sierra and is the OS that I use. High Sierra is OS 10.13. Maybe we are discussing different copy functions. I apologize for my confusion. I’ve not yet upgraded to 10.13. I seem to recall something that leads me to believe cmd-shift-C is related to copying multiple items but I cannot get that key-combination to do anything within Zotero of elsewhere. I’ll sign off and hope that someone else can be helpful.
  • Cmd+Shift+C is the quick copy shortcut. Check the export tab of Zotero preferences. Do you have BibTeX deleted as default or something else?
  • (it is - that's why I asked about drag & drop ; let's wait for @dstillman to check on the debug output)
  • @j.cossio: Start by disabling BBT and resetting translators from the Advanced → Files and Folders pane of the Zotero preferences.
  • @dstillman Yes, that worked. So it's something to do with the interaction between BBT and Zotero. I tried opening an issue on BBT, but it seemed it was going to be a problem with Zotero.

  • By the way, turns out that after disabling BBT, and enabling it again, the problem is solved :) If I can reproduce it again in the future I'll post here.
Sign In or Register to comment.