Forward-delete error ...

On 5.0.23-beta.8+1f5639da4, Windows 7

There still exists forward-delete related error.

Please have a look.


  • Could you explain what you're doing? When the note is clearing, you're just hitting forward-delete?
  • Yes. I drag last part and hit delete to erase selected part. But the whole note is gone.

    I hit I CTRL+Z to recover and tried again the same happened.
  • Can you go to the Config Editor in the Advanced pane of the preferences, right-click in the list, create a new boolean pref called extensions.zotero.debugNoteEvents that's set to true, and then generate a Debug ID for this?

    Does this only happen when you select right-to-left, not left-to-right? And you're definitely hitting forward-delete, not backspace?
  • edited October 17, 2017
    DebugID is D489671508.

    Usually this happens when I copy and paste some part of the text and immediately delete the last part.

    Right-to-left deleting may make the error more.

    The error is not consistent.
    Her I made avi file for your understanding.

    - I copied and pasted some part of the note.
    - Immediately I deleted pasted part by selecting right-to-left.
    - By CTRL+Z I undelted it.
    _ I tried again by selecting left-to-right...

  • What exactly are you pressing on the keyboard, and what input mode are you using?

    From the debug log, it looks like you're pressing Backspace and then Control (in that order), not forward-delete.
  • edited October 18, 2017
    To delete some words, I usually select and press Backspace or Delete.

    This time I tried to select text and press Delete key. The same error....

    I think this may happen when I copy, paste, and immediately delete before saving notes.

Sign In or Register to comment.