Preview Citation

  • @AndrewRRM I've added an option to choose a Preview Style that is not your QuickCopy style.
  • @dcartertod Where is the option to change the Preview Style, please?
  • It should be at the bottom of the Preview tab. I'm assuming you've downloaded and installed the newer version.
  • @dcartertod Ah, thanks. I presumed it would auto-update as other Zotero extensions. Can this be organised?
  • Two suggestions:

    1. can the name of the style be made visible above the style?
    2. might it be possible to allow the user see more than one style side by side? there is plenty of space in that column and that can be useful when learning new styles or testing style rendering when modifying styles.

    Thanks for considering
  • @sdflewrit783 Next version 0.0.4 which is released (and going forward) will auto-update, so once you have that one.

    Your two suggestions had crossed my mind. Will think on it.
  • Thanks. Great.
  • For some reason, this add-on won't install for me any more (I rebuilt my system and have been re-installing software).

    * Debian-based Linux
    * Zotero 6.0.13

    I download the add-on from the usual git URL (, but attempts to Install Add-on From File yields the following error:
    The add-on "%S" could not be installed. It may be incompatible with this version of Zotero
    Is this something others have had happen?
  • Could you say exactly what you did? That sounds like trying to import an incorrectly put together .xpi file
  • edited August 27, 2022
    Just the usual:
    * Download the .ZoteroPreview.xpi file from
    * Open Zotero
    * Tools > Add-ons
    * Drop down on cogwheel > Install Add-on From File...
    * Browse to downloaded file...
    * Error as shown.
  • What OS are you on? It's been reported before, but I really am not sure what's going on.

    I just released a new version in case it makes a difference (no idea if it will)
  • edited August 28, 2022
    Per the previous-to-previous post: Debian-based Linux (specifically PureOS, based on Debian 11 [bullseye]).
  • @jvoros Sorry! I missed that.

    When I first started I had had some issues with creating the .xpi, but those shouldn't occur any more. Can you try unzipping and rezipping it to see if that makes a difference?
  • edited August 29, 2022
    Tried testing integrity of zipfile:
     $ zip -T ZoteroPreview.xpi
    zip warning: missing end signature--probably not a zip file (did you
    zip warning: remember to use binary mode when you transferred it?)
    zip warning: (if you are trying to read a damaged archive try -F)

    zip error: Zip file structure invalid (ZoteroPreview.xpi)
    Also, trying the -F and -FF options produces no joy either, and attempting to un/re-zip also does not work.

    Oh well. Shame. I really did like this add-on.
  • Strange error. Tested on macOS Monterey with version 0.1.6 of ZoteroPreview. I used Firefox and Chrome to download the .xpi file. No corruption detected
    $ zip -T ZoteroPreview.xpi
    test of ZoteroPreview.xpi OK
  • edited August 29, 2022
    I tried d/l with Brave instead of FF. Same errors: both the zip -T test and the install error.
  • I have noticed that there are several different ways to download the "ZoteroPreview.xpi" file from the plugin page:
    1) From the main page of the plugin, in the code, there is a folder ZoteroPreview.xpi:
    - Download ->
    - View raw ->
    2) From the Releases ->

    I don't know how it works, but other Zotero plugins do not seem to put the xpi file directly in the code in this way, but only in the Releases page. For example:

    The different files are probably identical, but it may be useful to give the precise link you are using to download the file you are testing.
    I guess you have already tried, but I would try to remove completely the current file (also remove from the Trash folder), before downloading again the latest version from the Releases page.

    To make sure you have the correct file, you could check the file hash. I get the following MD5 checksum for the latest version:
    $ md5sum ZoteroPreview.xpi
    cacdb83a4e0a989e5271646cb1441fa1 ZoteroPreview.xpi

    I have tested on Ubuntu 20.04 (also Debian-based Linux), and everything is working fine (no file corruption and successful installation).

  • edited August 29, 2022
    Yes, this seems to have done the trick!

    There are two different file sizes present in the options for downloading from the links you've given above:

    1)-Download and 1)-Raw both produce a file size of 12.5kb;
    2)-Releases also produces the same.

    BUT: the link:

    which is accessed from the main repo

    has been producing a file that is 134 kb, and that it the one that has been failing install.

    So, there appears to be another version of the file that is accessible from one of the links on the git.

    I've now successfully installed the add-on again - the 12.5 kb file size, not the 134 kb one.

    Jolly good!
  • edited August 29, 2022
    I see. So I guess you were doing a right click -> save link on "ZoteroPreview.xpi" from the main page to download.
    This "folder" should probably be removed I guess.

    Maybe the Zotero Abstract Cleaner plugin should be moved to its own repository?
    I don't know if renaming the repositories would break the auto-updates. But if this is not too much trouble, maybe the name could be changed to Zotero Citation Preview, to avoid confusions with the Zotero PDF Preview?
  • Thank you both for your contributions. I'll see what I can do to clean it up.

    This is my first GitHub project, so I was guessing some of the way! :-)
  • hi, some sharing:

    - rename the repo does not affect the original link.

    - put each plugin in a separate repo would be more clear. for the xpi release, my suggestion is not to put it in the git repo itself, but in the release page of the repo.

    the binary file will not be handled by git and will seriously affect the size of your repo, making it extremely big after many updates.

    - as for how to easily update and release a plugin, here is my plugin repo. i use release-it package to update the version number and release it automatically. see
Sign In or Register to comment.