Zotero crashing Word

After automatic upgrade to latest version (5.0.22)
on OSX (10.12.6) Microsoft Word crashes when I try to enter a new citation and I get the following error message:

The operation couldn't be completed. (OSStatus error -609.) @[insertFieldRaw:document.m:1232]

I have tried:

Copying to a new doc
Reinstalling Zotero
Reinstalling Word (16.6)

If I have a new blank doc I can insert one citation but it crashes when I try to add a second.

Also the Word add in is now showing as not installed (but appears in Word), but when I try to reinstall I get:

[Exception... "Word does not appear to be installed on this computer. Please install Microsoft Word, then try again. @[install:install.m:153]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: file:///Applications/Zotero.app/Contents/Resources/extensions/zoteroMacWordIntegration@zotero.org/components/zoteroMacWordIntegration.js :: checkStatus :: line 212" data: no]

But note I can still add that first citation, even after reinstalling word. Odd!

I am using SBL 2.0 but the same thing happens with other styles.

Worked fine until the recent update. Have a doc with 36 footnotes.

Any ideas how I can solve this? Need to complete a paper shortly!
  • could you check the Word version again? 16.6 isn't a Word for mac version. 15.38 is the latest.
  • Definitely Version 16.6 (1710074). It is an Office 365 subscription, if that makes a difference?
  • There have been no changes to the Mac Word plugin from our side for a while. Are you sure it began with the Zotero update?

    You could try creating a new user account on your Mac and see if you get crashing there. If it doesn't crash there it would indicate corrupt user data files on Word's side.
  • For word version check you should follow Microsoft's instructions.
  • Curious, 16.6 was definitely what I was shown from Word -> About Word. However, having uninstalled all the Office files and reinstalled them it now shows 15.38 as expected! Looks like a corrupted Word installation. The Zotero for Word add-in has now installed without problem and everything seems to be working well again. Thanks for your help. Much appreciated.
  • 16.6 is the current Insider Fast version of Word for Mac. This is very early beta version, and it appears to have broken a lot of Add-In functionality (not specific to Zotero). I also found that I was not able to open the macro Security settings (Word crashed). You should revert to either the stable release or at most Office Insider Slow versions of Word.
  • I too had a major problem and ended up deleting Word for Mac, reinstalling and then starting from fresh. Likely the insider fast version contributed to this.
  • I'm having exactly the same issues. Zotero 5.0 and Word 16.6. I've tried EVERYTHING!!!! Reinstalled both several times. Crashes as the second citation attempt in a document. First citation works fine, but a second foot or end note crashed word.
  • See above -- 16.6 is not a stable version of Word for Mac.
  • Similar annoying thing for MS Word 2016 (365 Home) Build 8625.2139. This crash also changes shortcuts at least for copy/cut/paste.
  • @bubnilkin That is a stable (non-beta/non-Insider) release of Word, so your issue is different. It sounds like a lot of Word's behavior that is unrelated to Zotero is broken (copy, paste, etc.). That wouldn't be caused by Zotero, so I suspect you have some other issue with Word. I'd recommend re-installing Word. If the problem persists, please start a new thread and describe exactly what the issue is.
Sign In or Register to comment.