sync issues

I have been having issues with Zotero5.0 in Windows 10 Home on my Lenovo Yoga 720-IBLK laptop - report ID: 753393366.
Please help.
  • What's the message that you're seeing when you click the sync error icon?
  • It says: "An error occurred during syncing:" and the button for 'Report Error...'.
  • And nothing after the colon?

    We'll look into why it's not showing a proper message. These are the underlying errors:
    Win error 5 during operation open on file D:\Users\[…]\Zotero\storage\ECMNXIUB\[…].pdf (Access is denied.
    )" {file: "(unknown module)" line: 0}
    And the message it's supposed to show says this:
    The file '[…]' cannot be created.

    Check that the file is not currently in use, that its permissions allow write access, and that it has a valid filename.

    Restarting your computer or disabling security software may also help.
    You're getting these for lots of different files, so there's a good chance it's security software.
  • Yes, nothing after the colon. I have checked permissions, moved the zotero main folder to a different location, restarted the laptop multiple times; the only security software I have on this laptop is windows defender. I am hence not sure what's going on. Also, if zotero is not compatible with security softwares - at the very least windows defender, that is a big flag for usage.
  • It's not a question of compatibility. Zotero needs to be able to write to the files within its data directory. If something is preventing that, there's nothing we can do about it.

    We'll fix the colon issue, but if you look at the error report, you can see the folders within 'storage' (e.g., D:\Users\[…]\Zotero\storage\ECMNXIUB\[…].pdf ) that this is happening for. You can check the permissions of those folders and files — and 'storage' and the data directory itself — to see if they're somehow set to disallow write access.
  • edited October 10, 2017
    Is D: a network share or another local hard drive? If the former, have you tried moving your data directory to the local hard drive?
  • It is a local hard drive partition. I have tried giving full access to the folders of the Zotero directory to every available user and entity on the security tab, all together and then each individually - with no change in the sync error. I have no permission issues with any other program apart from zotero itself.
  • This was caused by files with the Windows read-only attribute. It should be fixed in Zotero 5.0.30, available now.
Sign In or Register to comment.