Running two accounts with Zotero - best practice?

edited October 3, 2017
I have two accounts, both set-up with different users and mail addresses. I want to keep the accounts separate. (One of them has two user-groups). Formerly, this worked well with different FF profiles. Have tried with a second instance of the app, renamed to be identifiable, logging the 2nd instance of Zot to my second account. But now both instances of the app connect only to one of my accounts. Can I replicate the old multiple profile behaviour with Standalone in some way? Any suggestions for best practices with two accounts? Thanks.
  • You can set up multiple profiles in Zotero Standalone the same way you did in Firefox.

    See here:

    And some discussion regarding Zotero 5.0 here:
  • Thanks for both of the links. I just realised that in the process described above I've also wiped 4000+ pdfs in my storage folder. I have physical backups for those and should be able to restore most of them once back at my desk in a few days.
    How do I get Profilemanager to start Zotero Standalone rather than Firefox? (I'm on MacOS 10.12.6).
  • Open the Zotero executable with the -ProfileManager flag (see the discussion linked above).
  • edited October 3, 2017
    Thanks bwiernik. Got the Profilemanager app to start with Zotero. However, after trying to invoke Zotero from the Profilemanager window ("Start Zotero") nothing happens. This is the case whether I use an existing of my profiles or create a new one.
    My sys.log states:
    Oct 3 16:35:30 AMW-1 zotero-bin[3029]: BUG in libdispatch client: kevent[EVFILT_MACHPORT] monitored resource vanished before the source cancel handler was invoked
    Oct 3 16:37:37 AMW-1 zotero-bin[3057]: assertion failed: 16G29: libxpc.dylib + 74307 [BF896DF0-D8E9-31A8-A4B3-01120BFEEE52]: 0x87
    Oct 3 16:38:32 AMW-1 zotero-bin[3064]: assertion failed: 16G29: libxpc.dylib + 74307 [BF896DF0-D8E9-31A8-A4B3-01120BFEEE52]: 0x87
    Any ideas?
  • @adamsmith @dstillman This has exceeded my knowledge of the profiles feature. Can you help out from here?
  • @kithairon: Are you running Zotero 5.0? What macOS version is this?
  • I'm using macOS 10.12.6 and Zotero 5.0.22beta6; rtf/odf-scan, Libreoffice, Zotfile and Zutilo plugins are installed.
  • Make sure you're starting zotero, not zotero-bin.
  • (I've created a documentation page for setting up multiple profiles.)
  • I indeed was trying to start zotero-bin instead of zotero – thanks for helping with this. Have in the meantime set up three new profiles successfully. Also just found your documentation – very useful.
Sign In or Register to comment.