Browser window UI errors (macOS)

- Launch Zotero
- Perform a few searches
- Eventually a search will stop returning new results and continue to display old ones
- Mousing over old search results causes them to disappear and be replaced by greyed out newer search results
- New searches do not work at all
- Spinning icon next to search bar
- Restart required, infrequently a crash alert occurs

Please watch this video to see the behaviour:

This error does not get logged by Zotero so I can't submit a report through that method.

This problem has been occurring highly regularly (maybe 80% of the time) since 5.0 and usually requires a restart.
  • I just tried some debug logging, it captured ~15k lines but the problem only happened briefly towards the end of the session. Not sure if the issue is captured. D641340369
  • edited September 28, 2017
    A bunch of people are seeing this, but we haven't been able to reproduce it ourselves, so anything you can do to figure out exactly when it occurs after a restart would be helpful. Some questions that might be useful:

    1) Does this happen only after editing an item?

    2) Does it happen with auto-sync disabled?

    3) Does it happen with all third-party Zotero extensions disabled?

    4) Does it matter what view you're in in the left-hand pane?

    5) Does it require you to start a new search while one is still ongoing?

    6) Does it matter what's selected in the middle pane, or what you've selected previously since restarting?

    (Once it occurs, be sure to restart before testing further.)
  • edited September 28, 2017
    I disabled auto-sync and all third-party Zotero extensions.
    I restarted Zotero.
    Without editing or selecting anything I opened the Advanced Search dialogue box. I searched for an item and selected it from the dialogue box.
    The item was selected in central panel. I added a note, but it did not appeared.
    In left-panel, My Library was selected.
    Debug ID is D155073780

    Then I restarted Zotero, I did some searches on search bar without problems.
    However, after using the Advanced Search dialogue box, the notes added or deleted do not appear.
    Debug ID is D387851464

    Thanks for your attention.
  • OK, we're getting somewhere. Do you still see problems once you close the Advanced Search window? There might be other issues, but I'm definitely seeing some weirdness when the Advanced Search window is open that goes away when it's closed.
  • Indeed, when I close the Advanced Search window I can add and delete the notes.

    However, I also have problems with search bar, but I can't identify for now the steps that make it always occur.
    I have a debug, if it may help. The Debug ID is D1820109856.
  • OK, the bug with the Advanced Search window open should be fixed in the latest 5.0 Beta — thanks for your help in isolating this one. The same bug may have been behind some of the other refresh bugs, but I'm not able to reproduce those the same way, so I can't say for sure yet. If you try the beta, let us know if you still have problems with the search bar.
  • Thanks, @dstillman
    I installed the beta. However it seems that there is still a small issue: if the window is open when a note is added, the item does not expand to see the added note.
    When I click in the arrow to expand, I can see the note.
    When I delete the note, I need to collapse the item to refresh.

    I'll report if there are other issues.
  • I'm not seeing either of those. What are your exact steps to reproduce those?
  • edited September 29, 2017
    1. Restart Zotero
    2. Add a note: the item expands to show the note
    3. Delete a note: the item collapses
    4. Open Advanced Search. Select the item.
    5. Add a note, without closing Advanced Search → no refresh
    6. Expand the item: the added note appears.
    7. Delete a note, without closing Advanced Search → no refresh
    8. Collapse and expand the item: the deleted note does not appear.
    9. Close Advanced Search.
    10. Add a note: the added note appears
    11. Delete a note: the item collapses

    version 5.0.22-beta.4+89babf883

    Thanks for you attention.
  • I'm having the search problem and have come here from another thread. I updated to the latest beta just now and am still seeing it. I have a set of reliable steps to replicate.

    1) Open Zotero. I'm in a collection of my library where the majority of my stuff is kept.
    2) Search All Fields and tags for the journal abbreviation ASAE by typing that in the search field. 12 articles appear. One has no pdf attachment. The eleven others have a pdf attachment each. Six have French titles, one Arabic, four are in English. All is as expected.
    3) Copy the journal title Annales du Service des Antiquités de l'Égypte from any one of the records.
    4) Paste into search, and start search. Search crashes with only three results fully visible, plus one in grey and several blank lines. Have to restart Zotero.

    BUT, if instead
    1) Open Zotero. I'm in a subfolder of my library where the majority of my stuff is kept.
    2) Paste into Search All Fields and tags again for Annales du Service des Antiquités de l'Égypte
    3) Search works but finds only FOUR articles: the one with no attachment plus two others, plus a new result that mentions the journal name. Nine expected results are missing.
    4) Deduce that there must be small differences in the full journal name in those nine, so search for ASAE again (which works whether typed or pasted, btw) copy and paste identical journal title into each of the twelve articles' info.
    5) Click sync. Sync does not appear to stop spinning, after waiting a long time.
    6) Restart Zotero
    7) Search All Fields and tags for Annales du Service des Antiquités de l'Égypte
    8) Search works but now finds FIVE articles: the four previously found one and one more. The other eight are still missing, so I think the paste of the journal name only sync'd one record before hanging.

    I have tried replicating these steps with English journal titles but it doesn't hang. Also, I don't see the not-finding-articles problem with other journal titles I've tried.

    Conclusion: there is something about having "Annales du Service des Antiquités de l'Égypte" in the clipboard that Z5 REALLY does not like at all! Even if I copy it from one of the articles that DOES appear in the search, it still hangs if a previous search has been executed.

    I hope this helps!
  • @Sopdet: Could we see a Report ID after you see this?
  • Also, if you can really reproduce this reliably from Zotero startup, a screen recording that shows it happening might be very helpful. If you're able to take one, you could upload to Dropbox or another file-sharing service and post a link here.
  • Here's a report ID: 570098433
  • @pnunolima: That second bug with the Advanced Search window open should be fixed in the latest 5.0 Beta.

    @Sopdet: You can try the 5.0 Beta as well to see if it fixes the problem you're seeing. Unfortunately I'm still not able to reproduce it, but I've put in a potential workaround for the specific error you're getting (though there might still be additional errors). If you're still having trouble with that, another Report ID would be helpful.
  • Thanks, @dstillman
    I changed to 5.0.22-beta.6+f7e2cd634 and it works fine.
  • OK, the refresh fixes are included in 5.0.22, available now via Help -> Check for Updates. Let us know if you continue to have trouble.

    @Sopdet: What you're seeing now is a separate issue, so I've split that off to a new thread.
  • Item selection that required switching to the library root is fixed in Zotero 5.0.23, available now.
Sign In or Register to comment.