Saving from Google Scholar broken after site change

edited 27 days ago
i am using zotero 5.0.21 with firefox. It was working fine till today morning but now it is not allowing me to save citations for journals or other research papers. it is only saving web pages.
please help me how to resolve this issue
«1
  • here is debug ID: D223128925

    previously when i open some paper in google scholar the zotero icon used to display a folder and when i click on that folder icon it automatically saved the citation. but now it is only showing save web page icon
  • I'm having the same issue. It might be because of the recent changes in Google Scholar
    https://scholar.googleblog.com/2017/09/better-ways-of-getting-around.html
  • it works still at other pages - go directly to the journal from google scholar
  • Yes, google scholar is broken, thanks for letting us now about the update. We'l work on a fix asap.

    This also means "Retrieve Metadata" will currently not work in many cases.

    @dstillman if you could adjust the thread title and pin this (or create a new one).

    The earliest I can look at this is tonight (ET).

    CC @zuphilip
  • @stephan surely it works with another pages, i have tried to reset translators but still the problem is not fixed....
  • @s.shah Like adamsmith said, when Google Scholar changed its layout, it broke the Zotero translator. They are working on fixing it as soon as possible. They will post an update here when it’s fixed.
  • let's hope it will be solved quickly. It is not nice, that google scholar cares about users of endnote etc. but not about Zotero
  • (while I'm working on this, clicking the "Endnote" link should work for Zotero, too)
  • Update: I have a very basic version working locally. Still need to make sure this is robust, but this means google hasn't made this too hard (if anything, it's gotten a little simpler than before) and they haven't changed a ton, so this won't be a long wait.
  • Google Scholar should now work again. Update your translator from the General tab of the Zotero preferences by pressing "Update Now". You may have to restart your browser (@adomasven -- is that still necessary?).

    I've tried to test this on a range of US and international versions of google scholar, but obviously may very well have missed something. Any problems let me know.
  • Thanks very much @adamsmith worked for me w/o restarting Chrome.
  • Hi @adamsmith this fix doesn't seem to work from me (i'm browsing from Israel), on win 10. I even took Zotero off chrome and put back on and did all the updates but it still doesn't seem to work. Any suggestions? Thank you!
  • @idokatri: Can you provide an example URL that doesn't work and a Debug ID from Chrome for loading the page and trying to save?
  • So I usually can just pick a bunch of reference from a page like this:

    https://scholar.google.com/scholar?hl=en&as_sdt=0,5&q=un+declaration+on+indigenous

    this is my DebugID- D1274390554

    I hope I did it right...
  • Are you sure you started that before loading the page? If you only see the webpage icon, we don't need it to cover the save part, but we do need to see it for actually loading the page.
  • Okay. I now did everything again. I apologize, it's my first time.

    The new debug ID D1413482576
  • It worked for me for a few hours, and then stopped working. Here's the ID
    D278219633
  • @adamsmith it worked for me
  • @idokatri: That seems to be for loading the Google Scholar home page, not the actual search results page you're trying to save from.
  • In any case, if this isn't working for you, try resetting translators from the Advanced pane of the Zotero Connector preferences.
  • I did that and restarted the browser and it still doesn't work...
  • Are other sites also not working for you — e.g., an Amazon book page — or just Google Scholar?
  • Amazon and the library still works perfectly....
  • Try resetting translators in the Advanced → Files and Folders pane of the Zotero preferences, and then resetting translators again in the Advanced pane of the Zotero Connector preferences. If that doesn't help, also try disabling any other Chrome extensions you're running.
  • It worked! thank you! I did all that and removed the google scholar extension and not it's okay.
  • @dstillman Resetting fixed it. Thanks.
  • I reset translators and styles and now when I go to Export page, I can no longer set Default Format, it just says Loading ...
  • Working again now after restart.
  • I just installed and used Zotero for the first time today. I managed to save a few items from Google Scholar but at some point I got a message that "error occurred while saving this item" Then, I tried items that I saved before and it now did not work.

    Please see report ID 281008554.

    Thanks.
  • BibTeX not found
    @chotibhak: If you click the BibTeX link in the citing window in Google Scholar, do you see BibTeX code (beginning with, e.g., "@article"), or do you get an error?
Sign In or Register to comment.