Getting bib details into Zotero on an Android device

I carry a powerful Android phone with me at all times and assumed that I would be able to add items to my Zotero library using only that device.

Rather surprisingly it looks like I cannot.

I search my university library ( and get to the details of the item of interest. At that point I:

1. Tried to use the Zotero bookmarklet for Chrome on Android - didn't work.
2. Tried to use the Zotero bookmarklet for Internet browser on Android - didn't work.
3. Saved the details in RIS format - no way to import this to Zotero library on Android / web.
4. Saved the details in BibTeX format - no way to import this to Zotero library on Android / web.

It seems that my Library is doing its bit in supplying the details in a number of ways (and I could get these into EasyBib, EndNote and RefWorks with little friction) but Zotero does not provide a way of capturing any of them when on Android.

Given that so much of what we do now is handled quite capably by Android, I am surprised that Zotero has not developed that way. Or have I missed something?
  • The bookmarklet generally works. Can you give more detail about what "didn't work" means?
  • edited September 21, 2017
    I followed the instructions here ( ) to get the bookmark in Chrome on my Android phone (S8).

    When I go to and search for any book (e.g. this one ) and then use the "Save to Zotero" bookmark, nothing (literally nothing) happens.

    If I go to the same URL in Chrome on Windows and click the "Save to Zotero" extension icon, the item is saved in Zotero.
  • Unfortunately the instructions are for older versions. The android browser and Chrome for android have changed how they treat bookmarklets many times over the years.

    As far as I can tell, the current version of chrome for android no longer supports bookmarklets at all. The location bar isn't actually a location bar and any javascript in it gets interpreted as a search. And as you saw, if it's triggered from the bookmarks menu it just can't figure out what to do with it at all.
  • This workaround worked for me:
    • Enable chrome syncing on desktop and android
    • Add bookmarklet on Desktop Chrome and wait for it to sync with android
    • When on the page you'd like to save, begin typing the name of the bookmarklet ("Save to Zotero") in Chrome on Android & click the bookmarklet when it comes up.
  • Indeed. It seems you don't need to force the sync to get it to work. I just couldn't get it to suggest the bookmark at first when typing into the bar.

    @noksagt did you actually get the save to go through?
  • fcheslack: yes, the save goes through. I tried an amazon book. Naturally, you need to be logged in to the Zotero site.

    Some pages give an error, but the import still happens.
  • @noksagt Many thanks for the advice - it's not a process I would have thought to try and it deserves to be more widely advertised in the Zotero community! I've just tried it and it worked for the main use case I have: my university's library catalogue.

    Thanks again.
Sign In or Register to comment.