Trouble launching Zotero 5.0

Hello,

A few months ago I installed Zotero Standalone on my computer (Windows 10, 64 bits) with the Firefox plug-in. Everything was working well but I have been away for a few weeks and now when I want to launch Zotero Standalone, a message appears: "An error occurred when launching Zotero" (translated from French) and when I press OK it closes Zotero. I tried to restart my computer, I also tried to uninstall and install again Zotero Standalone but nothing helped, I still have the message and it is still impossible to open it. I don't know what changed during my absence but it is not working anymore. Could you help me please?

Thanks!
  • Also I tried the procedure described in the "Reporting Startup Errors" section (https://www.zotero.org/support/reporting_problems) but it does not work neither with "-ZoteroDebug" nor with "-jsconsole", it just says "Windows does not find .... Check that you entered the correct name and try again."
  • That just sounds like you haven't specified the right path to Zotero. Could you paste exactly what you have in the run window here (Also, don't translate error messages; please just copy them in the original language).
  • Ok sorry, the message I get when lauching Zotero is "Une erreur s'est produite lors du démarrage de Zotero."

    Also in the run window I have "C:\Program Files (x86)\Zotero\zotero.exe -ZoteroDebug" but when I click OK, it says "Windows ne trouve pas 'C:\Program Files (x86)\Zotero\zotero.exe -ZoteroDebug'. Vérifiez que vous avez entré le nom correct, puis réessayez."
    Same thing if I replace "-ZoteroDebug" with "-jsconsole".
  • edited 6 days ago
    That still means you're using the wrong path to the zotero.exe file, or possibly putting quotes in the wrong place or omitting a space. First make sure it starts up with just the part leading up to zotero.exe. You should be able to do that just by browsing to the zotero.exe file from the Run dialog.
  • (are you getting the path by using the "browse" button? That's the most reliable way to get it right)
  • Yes I use the "browse" button and indeed when I use the path without "-ZoteroDebug" it launches Zotero, though it still fails.
  • Right, so add a space — after any quotes that appear (we'll clarify that in the instructions) — and then add -ZoteroDebug.
  • Ok my bad, I didn't get that it was after the quotes that you had to add "-ZoteroDebug"...

    Ok so ZoteroDebug didn't give me anything but with -jsconsole that's what I get (all the pink lines):

    Timestamp: 15/09/2017 09:53:28
    Error: 1505462008840 addons.xpi-utils ERROR Failed to write add-ons list to profile directory: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIFile.moveTo]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: resource://gre/modules/addons/XPIProvider.jsm -> resource://gre/modules/addons/XPIProviderUtils.js :: this.XPIDatabase.writeAddonsList :: line 1534" data: no] Stack trace: this.XPIDatabase.writeAddonsList()@resource://gre/modules/addons/XPIProvider.jsm -> resource://gre/modules/addons/XPIProviderUtils.js:1534 < this.XPIProvider.checkForChanges()@resource://gre/modules/addons/XPIProvider.jsm:3864 < this.XPIProvider.startup()@resource://gre/modules/addons/XPIProvider.jsm:2830 < callProvider()@resource://gre/modules/AddonManager.jsm:237 < _startProvider()@resource://gre/modules/AddonManager.jsm:790 < AddonManagerInternal.startup()@resource://gre/modules/AddonManager.jsm:976 < this.AddonManagerPrivate.startup()@resource://gre/modules/AddonManager.jsm:3033 < amManager.prototype.observe()@resource://gre/components/addonManager.js:65
    Source File: resource://gre/modules/Log.jsm
    Line: 753

    Timestamp: 15/09/2017 09:53:29
    Error: NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIPrefService.savePrefFile]
    Source File: resource://gre/components/SanityTest.js
    Line: 285

    Timestamp: 15/09/2017 09:53:30
    Error: NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIRDFRemoteDataSource.Flush]
    Source File: resource://gre/components/nsHandlerService.js
    Line: 392

    Timestamp: 15/09/2017 09:53:30
    Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIRDFRemoteDataSource.Flush]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: resource://gre/components/nsHandlerService.js :: HS_store :: line 392" data: no]

    Timestamp: 15/09/2017 09:53:39
    Error: A promise chain failed to handle a rejection. Did you forget to '.catch', or did you forget to 'return'?
    See https://developer.mozilla.org/Mozilla/JavaScript_code_modules/Promise.jsm/Promise

    Date: Fri Sep 15 2017 09:53:29 GMT+0200
    Full Message: Win error 1251 during operation move on file \\perdita\achalard\Windows\Application Data\Zotero\Zotero\Profiles\2lwalqal.default\sessionCheckpoints.json.tmp (Cette opération n’est prise en charge que lorsque vous êtes connecté au serveur.
    )
    Full Stack: JS frame :: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js :: PendingErrors.register :: line 194
    JS frame :: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js :: this.PromiseWalker.completePromise :: line 715
    JS frame :: resource://gre/modules/Task.jsm :: TaskImpl_handleException :: line 456
    JS frame :: resource://gre/modules/Task.jsm :: TaskImpl_run :: line 331
    JS frame :: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js :: Handler.prototype.process :: line 935
    JS frame :: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js :: this.PromiseWalker.walkerLoop :: line 813
    JS frame :: resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js :: this.PromiseWalker.scheduleWalkerLoop/< :: line 747
    Source File: (unknown module)
    Line: 0
    Source Code:
    0
  • edited 5 days ago
    [extra output removed — D.S.]
  • Cette opération n’est prise en charge que lorsque vous êtes connecté au serveur.
    You have your Zotero data directory on a network share, and network shares don't always properly replicate the normal filesystem behavior that Zotero (or, really, the Mozilla/Firefox code that Zotero uses under the hood) requires. If you're disconnected from the server, as the error message suggests, try reconnecting. If that doesn't help, you may need to move your data directory to the local hard drive or talk to your IT department.
  • Ok, I actually do get a lot of issues with this network... Thanks for your help!
Sign In or Register to comment.