Customising citation style works not as expected

edited September 12, 2017
Hi everyone, I have two related questions about customising citation styles.

For my document, I need a style whereby in-text citations are mentioned as footnotes, with only Name+Year as the details given in each footnote. It seems the "Chicago Manual of Style 16th edition (note)" style (which is Name+Title) comes closest, as it only needs customising to change Title into Year.

To that end, I followed Zotero documentation and tried to download this modified style from the Zotero Style Repository. However, there, the preview that it shows me is very different (much more details is shown, and NO footnotes) from how this style is (correctly) applied in my document. How can I modify the style as desired?

Also: can the FootnoteText style, that Zotero employs to list the references, be laid out on 2/3 columns? I see no such option in the style settings, and there seems anyway to be a bug (see my previous thread) with how Zotero actually follows style settings for listing references! If I change the footnote settings directly from Word's ribbon, Zotero makes a mess of the footnote section, so it probably has to be done through Zotero somehow.

Using Word 2016, Zotero, Firefox 55.0.3, Win 7. Many thanks!
  • How are you editing the style? You don’t download customized styles from the Zotero repository, so it’s not clear to me exactly what you’re doing.

    General instructions for editing styles here:

    For you, the easiest would be to download the Chicago author-date style and change class=“in-text” in the first line to class=“note”

    If you don’t want parentheses around the author-date, delete the prefix and suffix under the citation section.

    Regarding your second question. No, Zotero just tells Word to insert a footnote using its built in system. Word has no ability to collapse footnotes like that.
  • Thanks, I should be all-clear now!
  • edited September 12, 2017
    Small issue:
    I've edited my custom style accordingly, and saved it under c:\..\zotero\styles\

    However, this new style is not visible under the list of citation styles in Zotero's document preferences (in Word).

    Zotero appears to simply have overwritten the base Chicago style, which would have been fine with me, except that there is a bug here as well: while old citations are formatted according to the CSL, new citations seem to be added in accordance with how the style was before I edited it, e.g. with the ( and ) pre/suffix.

    This bug interacts with the other one I've reported, whereby in-text citations do not (always) follow settings of the FootnoteText style that should govern them. Therefore, not only is the citation inserted according to an obsolete template - the font size for it is not good either!

    Is there no easier way to create a custom style and have it applied consistently to a document, without issues intefering that relate to old/built-in styles?

  • You need to change the style title and ID in your custom style. Also, you should install styles from the Cite pane in Zotero preferences, not by manually adding them to the folder.
  • My guess is that you're not changing the style ID? Also, you'll need to change to a different style and back for changes to a style to take effect.
  • In order to keep the original Chicago style, but also have your new, modified style do the following:
    - change the filename: chicago-longtalker.csl
    - open the file and change the ID and self-link to match that to chicago-longtalker.csl

    Then you can use both styles and it won't get overwritten if a new chicago style comes out.
    Somehow you then also need to refresh the style in your Word document.
  • edited September 13, 2017
    @damnation: I edited the tag of my custom style, but I'm not sure what to put as an , since for all my styles, that contains an URL to

    After installing it from the Cite menu under Zotero Preferences, the style now show up as an available style under the Zotero Word Preferences. However, the citations are all a mess, which is indeed reflected in the CSL: when I open it, the changes I had made to make the references appear in footnotes, and with no brackets as a prefix/suffix, are all gone.

    Sorry that I am catching on slow with this...
  • right, you want to change that link to Zotero -- the new link doesn't have to actually exist, but it needs to be different from any existing ID
  • edited September 13, 2017
    Not a problem :)

    for the ID and self link put it like
    Then go into Zotero's preferences - cite - styles - use the + button and find the style and install it.
  • Thank you so much for your unbelievably prompt help.

    So I created a copy of the built-in chicago-note-bibliography.csl, which I named _MC.csl ; I edited that file to read:
    The style shows up in Word, and (at least in a new sandbox document that Ic reated to test this) seems to format the references as expected rather than create the mess it did in my main doc.

    Now all I need is to customise the default template (which includes DOI, page numbers etc), to the following simplified template:

    FirstAuthor et al.: "Title" (journal, year)

    However the contents of the tag in _MC.csl, too long to paste here, don't seem to contain anything related to DOI etc that I could just edit to fit my desired template...
  • edited September 13, 2017
    Can you share your code here in a secret Gist?

    What is it that you want exactly? I'm not getting it.

    I have a large doc, and its references need to be put in footnotes, according to the template:

    FirstAuthor et al.: "Title" (journal, year)
  • Let me know if i should clarify further what i am tryig to do if it still doesn't make sense :) Thanks!
  • This will take a lot of work to get the fullnote style edited to match your requirement. I'd recommend starting with this style and adding on. A lot easier to do: Chicago Manual of Style 16th edition (note)

    Is this style for any specific journal/uni?
  • You're right that it's easier to start from that one. But still, if you say the markup is not trivial to edit and customise, then how do I change the existing reference template, which is
    Author, 'Title'
    ..into the one I want, which involves adding "(journal, year") at the end?

    This is just a particular style that the organisation that will get this document (the EU) want people to use!..
  • edited September 13, 2017
    and also, what to do with my main document, where any of these footnote styles that I apply lead to references being erroneously typed in different fonts (and changing the style back and forth, or restarting word, doesn't help) ?
  • the page at did not help, much as I tried... any more ideas at all? Thanks again for your help.
  • These Chicago styles are complex. Do you only reference journal articles? If yes, I can look at it over the next few days.

    Regarding the either issues, can @adamsmith help with this?
  • Unfortunately I am *very* pressed for time so this won't help. Am I correct then, that for all intents and purposes, it is not possible for a CSL-novice to customise the template to also have journal and year at the end?
  • Have you tried to use the CSL visual editor to add that?

    The CSL variable for journal title is container-title

    Beyond that, the linked step by step instructions above do go through each step you need to follow to edit the style by hand yourself.
  • It is totally doable, but you just picked one of the most complex styles to learn from.
    Chicago is an extremely robust style, but makes it a lot harder to edit (and understand for a beginner). This style has a lot of lot of predefined macros, so it's harder to get where what is happening.

    Here is a rought draft that'll give you an idea.
  • damnation , this works just fine for now, thanks so much to all and ill respond more fully soon
  • So just to wrap up, all that was needed to respond to my initial query is contained in this thread. Thank you so much to members of this wonderful community - in particular damnation and bwiernik - for your continued support.
Sign In or Register to comment.