Changes to the "Bibliography" style not reflected in formatting of bibliography text

Hello everyone,

I tried to change the font-face of my Bibliography style, however this change is not reflected in the text with which Zotero displays my references in the end list, which seems to stubbornly follow that of the Normal style, even when the two styles' fonts are different.

This happens even after deleting&reinserting the Bibliography, restarting Word, and updating Zotero and the ZoteroWordForWindowsIntegration addon (versions and 3.5.6 resp.) in my Firefox (v55.0.3).

Is this a bug or a "feature" ? :-)

Many thanks!
  • If you place the cursor in the Zotero bibliography, what style does it say it is?

    What version of Word and Zotero?
  • placing the cursor in the Zotero bibliography corretly shows the style as "Bibliography"...

    Word 2016, Zotero
  • edited September 10, 2017
    If you click Modify Style under Bibliography, what style does it say that it is based on? And just to confirm, if you make a major change to that style (e.g., set everything to bold), nothing changes? Does the problem also occur in a new empty document?
  • edited September 12, 2017
    The based-on style is indeed Normal, but that should still mean that any changes made to the Bibl style are reflected in the text formatting , no?

    Funnily enough, when I try your suggestion and make the text bold in the style, the change is visible immediately, unlike any change to do with the font type (typeface) or font size, which stubbornly stay as they were!

    And all of the above happens when I try it out in a new empty document...

    This looks like a bug to me! Thoughts?

    Thanks for your help by the way!
  • Update: It seems that with newly-added citations, the references are formated correctly, according to style settings. It's with the older / existing ones (of which there are many!) that the settings are not followed, at least not with regards to fontsize. When I have more time I can do a more detailed bug report with replication steps if it helps.
  • Yeah, I’m not sure what could possibly cause that without more detailed steps.
  • I've just experienced the font size issue, too. It seems to be related to a bug in Word's Fields feature, which Zotero uses for Bibliography formatting. You can workaround it by changing the typeface/size of one of the references in the bibliography, selecting the first word, and choosing "Update to Match Selection" in the dropdown for Bibliography in the Style pane.
  • thanks, will try that!
Sign In or Register to comment.