Storage sync never ending

When I try to sync my files storage, there's always 1 or 2 files which don't, and prevent the process from ending. Is there a way to figure out which files are actually not synced, so I can try to delete and reimport them?

  • Hi Thomas

    I struggled with this for ages, posted a few times for advice, but I never really worked out what was causing this, but mine is OK now. I think maybe duplicate files are made somehow occasionally, and zotero can't figure out what to do. What seemed to work in the end for me was fairly radical, and I'm not even sure it was what solved the problem, me not being a computer guru, but here's what I did.

    The basic idea is to start with a fresh set of data, based on what is stored in your desktop computer, so you know there are no spare files hanging around. I exported all my records to my hard disk (gear menu item) in zotero file format. Then turned off the automatic sync to the webdav storage site and zotero - make sure you have a note of your zotero username and webdav connection site details. Delete your entire library, then reset TO the zotero store from preferences so the data at zotero is destroyed too (I bet you are loving this..). I then uninstalled zotero, and removed the zotero profile from the applications/preferences folder in firefox (I'm using a PC - search help for zotero profiles or zotero storage for details I think). Then go to your webdav store - for me I can do this using explorer, and just delete everything inside the zotero folder. Now you are back to square one, except you have the data you saved at step 1. Download zotero 1.5 - I'd then check the zotero profile and make sure it is empty. Then import the records you saved. Your library local store should be back to normal. You then go to preferences and add your username and connection to your webdav store and turn on automatic updates and your computer should start to build up the storage again, and hopefully it will be all OK. After I'd done this I also resolved just not to worry about the little green arrow thing - who cares if it spins around all day? And everything is now OK.

    Bear in mind I have no idea about how the computer is doing any of this, so if this seems too spicy .... I can't guarantee for you this description is totally flawless either - its the best I can remember from a few weeks ago. Also I saw posts from the staff saying that the zotero server times out after a couple of minutes. I think this is so individual computers can't hog all the server time - so if you have lots to upload it will take time, possibly hours, as I presume it will be done in chunks. I also saw it is usually better to save the entire zotero profile rather than export the records, but I did it the export way and it was OK.

    Or you could skip straight to not caring about the little green arrow thing and the error reports - it still seems to work OK otherwise anyway. I never noticed any missing data. Next upgrade will solve all these niggles. This zen approach will also save you yet more hours wondering what is going on too.
  • Thomas: Restart Firefox and try again, and if you're getting any errors in Report Errors (under the gear menu) after the stall, send in a report and post the Report ID here.

    If there are no errors, before trying all of lakelander's steps (export/import in particular should be a last resort), I'd recommend 1) deleting the 'zotero' directory your WebDAV server and 2) using Restore to Server in the Sync->Reset pane of the Zotero prefs to clear data on the Zotero server. Then try syncing again.

    If that doesn't work, you can also run a sync with debug output and send us the output at, referencing this thread.
Sign In or Register to comment.