Zotero Scholar Citations add-on is writing "00000" when updating citation count

edited August 17, 2017
Zotero 5.0.11 and Zotero Scholar Citations 1.9.2

If I right-click an item and select "Update citations", Zotero Scholar Citations is updating the citation count field (in Extra) to be "00000". This is true for an item that already had a non-zero citation count from the last run of this feature.

I am noticing the issue today but it could be related to my actions yesterday. I know the add-on was working fine for past few days including yesterday. The, I selected about 100 items and asked for citation count update. I know this can cause a block-out from Google Scholar but I wanted to get as far as I can and let the block sit for some time.

I did not get any block message from the add-on. But could it be possible that Google Scholar is acting smart and replying with "00000" to any request coming from my side?

Or, is there an issue with the add-on?
  • You are probably locked out by Google Scholar. Try to go to Google Scholar website manually. Does it load?
  • edited August 17, 2017
    Yes, I am able to login to Google Scholar (GS) website. How does GS lock a computer out; is it based on IP?

    And even if it is locking me out, shouldn't the add-on know that? and if it knows that, shouldn't it then NOT update the data with the "00000" received? I lost the citation count on hundreds of articles. Not a big deal, as long as I can get a valid update later.
  • More: When I drag-drop an item from My Library to a group library, the citation field changes from whatever number was there to "00000"
  • Does it work correctly on a different computer or if you restart your computer and connect through a VPN?
  • edited August 18, 2017
    Citations were updated correctly when I ran the feature from another computer (but the same library, sycned via account). However, it worked for a short window of maybe 10 items and then went back to "bad" update mode where it over writes an existing citation count (for example "02073") with "00000".

    Note, my question is not about why I can't get a citation update. I know Google Scholar will do a lock-out after certain number of update requests.

    The question is, when a lock-out happens the add-on should simply not update the citation count. If Google Scholar is only replying with 00000 and no lock-out message, maybe the add-on could have a rule that citation numbers can only increase. I know that's not perfect, but something along such a rule based system can prevent this bad update.
  • You'd have to ask the developer. My guess is that it's not detecting that it's been locked out correctly because GS changed its lockout screen/behavior.
  • edited August 18, 2017
    Done, just sent an email to the developer.
Sign In or Register to comment.