connector problem with taylor and francis site

Hi there,
I was trying to save multiple article at once from a journal issue, here:

a number of things went wrong. First of all I got a complaint from my Reader add-on
TypeError: bundlePreferences is null1715

no idea what's triggering that, so I've disabled Reader for the moment. But when I tried to save multiple articles, Zotero gave me the 'An error occurred while saving this item'

Report ID: 1559766125

FYI saving individual by clicking through to the article page, works fine.
Aaaaand, now I tried saving just one article using the yellow folder, that worked and now I can save more than one article. So it's fixed? I hate intermittent problems. Hope there's some useful info in the report.

  • Something is up with T&F and Firefox, I'm looking into it. In the meantime, if you can test, does the same occur with Chrome?
  • Happy to help out. Don't normally use chrome(ium - I'm on linux at the mo.)
    Installed the connector.
    When I first navigated to the page, it wasn't picking up the data properly - it was only offering to save it as a web-page, no yellow folder option. After a couple of refreshes, the yellow folder appeared, and I could save more than one article at once. It was surprisingly slow, but did work.
    Only error in the console was this one:

    [JavaScript Error: "Script injection timed out" {file: "chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/background.js" line: 263}]
  • Right, this is a matter of T&F translator idiosyncrasies and Connector code. Chrome behaves slightly differently, which is why it works. We'll look for a solution, but it will not be immediate. For the moment saving articles one by one will work in Firefox, or multiple articles with Chrome.
  • I don't recall the T&F translator to be terribly complicated -- is there anything we can change about that that makes this work more smoothly?
  • But to answer this succinctly, Zotero should handle this properly, or alternatively processor functions should return Promises, but I don't think that's a possible short-term solution, even if it would make sense in the long-term.
  • Any news on the t&f connector? I just run into similar problems with new FF-Browser. Multiple saving from journal issue page returns error. saving from individual page only save metadata without pdf (it at all). Only working workaround for me: go to individual page. open pdf in new tab. Save pdf to zotero. Go to Zotero. Search for metadata to pdf. click on pdf and change name of pdf according to metadata-set. Problems for me started with new FF/Z5 combination.
    I am totally frustrated and thinking about reversing to FF52lts and Z4 for as long as possible.
  • This has been fixed. Provide a link where you see the problem and submit a Report ID
  • I'd actually prefer if you could run through all of these:
    T&F works in general, e.g. with the link above.
Sign In or Register to comment.