[5.0.11] Stand-alone note "date modified" is updated by just viewing the note

If I click on a stand alone note in the middle pane, it's date modified is updated to current time. Sometimes, I need to click in the note in the right pane (but still no modification) to see the date modified get updated. This is misleading, because nothing in the note has changed.
  • This shouldn't happen. If you can reproduce it, we'd want to see a Debug ID that shows it happening.
  • Tried but could not replicate it today. The affected notes are still showing 8/13, the day I reported this. It had happened a couple times before that. I will keep an eye out for this and update here.
  • I have just upgraded from 4.0.29 -> 5.0.26 (after putting off the major version switch to 5.0 for a long time!) and immediately saw this issue with my standalone notes. I have a LOT of standalone notes, making this a major concern.

    Repeated a few times and then logged another repetition to D43315296.
  • Update: I am using a dual-boot Win8.1 / Manjaro Linux laptop with Zotero installed under both OSs. Last week I upgraded Zotero from 4.0.29 under Linux and saw this issue. Today I upgraded from 4.0.29 -> 5.0.28 under Win8.1 and saw the same issue occurring there. I noticed this time that some notes seem immune to the issue, and submitted a longer debug log D766520405 where I am repeatedly changing view focus in a collection of 14 notes, and 10 have their date modified updated while 4 notes do not, seemingly no matter how many times I switch focus on/off those notes. Perhaps the difference between these notes and the rest will be a useful clue as to the cause of the bug.
Sign In or Register to comment.