How to stop automatic redirect.

Currently Zotero automatically redirects my requests to www.sciencedirect.com through the proxy at www.sciencedirect.com.proxy.lib.uiowa.edu.
I no longer want it to automatically redirect through this proxy.

Can you tell me how to stop the auto-redirect?

Thank you!
  • Open the preferences in the Zotero connector for your internet browser and either disable proxy redirecting or just delete the proxies you don’t want to use any longer.
  • I am using firefox, so there isnt a connector. Is there a way to do it in firefox?
  • Same thing in the Proxies tab of the Zotero preferences
  • Where are the preferences for Zotero connector in Safari? I'm in Safari->Preferences->Extensions with Zotero connector installed and I don't see the preferences anywhere. Am I in the wrong place? I'm trying to set up the auto-redirect through Concordia U proxy.
  • In Safari you have to right-click on a webpage background and select "Zotero Preferences…". (Generally, though, proxies should be set up automatically and you should only need to adjust the preferences to remove them.)
  • Thanks! I only get the following options: 1. General: Zotero Status and Save to Zotero.org; 2. Advanced: Report Errors, Debug Output Logging, and Translators. No proxies. Maybe I should reinstall?

    I had GMU proxy automatically originally but when I moved to Concordia the proxy never materialized. It hasn't been essential but ideally I'd love to have this feature.
  • I cannot find a proxy tab in Zotero Preferences. I find tabs for "General", "Sync", "Search", "Export", "Cite", and "Advanced" , but not for "Proxies". Also none of those tabs have content related to proxies. What to do?
  • edited 12 days ago
    @erazlogo: Oh, sorry — there's no proxy support in the Safari connector because of limitations in the Safari extension framework. @adomasven knows the details better. It's possible we could support manual configuration and basic redirection — i.e., if you type jstor.org, it changes the URL to jstor.org.proxy.uni.edu — but as far as I know we wouldn't be able to do automatic proxy detection or automatic host association.
  • @jfagan11: If you're using Zotero 4.0 for Firefox in full mode (i.e., with Zotero Standalone closed), you'll have a Proxies tab in the Zotero for Firefox preferences. If you're using Zotero 4.0 for Firefox in connector mode (with Zotero Standalone open), there's no proxy support. If you want to use Firefox and the standalone app together, upgrade Zotero Standalone 4.0 to Zotero 5.0 and install the Zotero Connector for Firefox, which does have proxy support.
  • Thanks, That worked nicely. Have upgraded to vers 5.0, installed the connector for firefox, and found preferences and removed the offending proxy.
  • @dstillman: thanks, got it.
Sign In or Register to comment.