Zotero Firefox Connector does not work (clicking on button does not lead to any action)

Dear Zotero developers,

I have successfully upgraded to Zotero 5.0 from the old Zotero Firefox add-in. However, I encounter an issue with the Firefox Zotero Connector.

Zotero 5.0 is running well and the installation of the Zotero Firefox Connector also worked well. The new connector also shows the "Z" button in the Firefox menu bar. However, clicking on the "Z" button does not perform any action at all. Neither on a website, nor on Pubmed or Google Scholar. It simply doesn't do anything. BTW, the button always shows the "Z" icon and never changes to any other icon like the book, article or other icon.

I used the and it says that "Zotero Connector Server is Available". So, there seems to be no problem with my installation.

Thanks in advance for your help.

My system is:
Windows 7, Firefox 45.0.1, Firefox Zotero Connector 5.0.11, Zotero 5.0.4
(I don't have admin rights on my computer, so if Zotero or Firefox need to be updated to fix the problem, I have to ask our IT department)
  • Firefox 45 is no longer supported by Mozilla or us — you'll need to upgrade to Firefox 52 ESR. (Also, there were many more versions of Firefox 45 ESR after 45.0.1, so that hasn't been an appropriate version to be running for a long time.)
  • Thanks, I will ask the IT department to update Firefox and will report whether this fixes the problem with Firefox Connector.
  • Thank you very much, Dan!

    Our IT department was quick and updated to Firefox 54.0. Now, also the Firefox Zotero Connector works!

    This issue is solved. Thanks.
Sign In or Register to comment.