Report ID 522622006 - Zotero 5.0 won't install Word Processor plugin

Report ID 522622006

In Zotero 5.0, I opened Preferences > Cite > Word Processors. I clicked the top button, "Install Microsoft Word Add-in," and nothing happened. The text in the Microsoft Word box still reads, "The Microsoft Word add-in is not currently installed," and when I open Word, there is no Zotero tab or Add-ins tab.

I am running Word 2013 (15.0.4945.1000) MSO ( 32-bit, Part of Microsoft Office Professional Plus 2013.

I have tried restarting Word and Zotero.

I'm a little worried about this basic function not working, as I will be teaching a lot of new grad students to use Zotero in about a month, and am in the process of creating new support videos for my campus over the next couple weeks.
  • Is this a new machine? Does it work if you run Zotero as administrator?
  • No, not a new machine. I'm not sure what you mean by running Zotero as an administrator. I am logged into my machine in the standard way (my campus login and password).
  • edited July 21, 2017
    It would be impractical for me to call someone from I.T. to use their admin password to log into my machine, and I am not getting a popup saying that the computer requires an administrator password to do this install. There is just nothing happening at all.
  • Right. If you don't have administrative rights on this machine then the auto-installer is likely to not work. We'll look for a way to make that explicit.

    However, you might be able to install using the manual installation instructions.
  • Logged into my machine as Administrator, I was able to install the plugin. However, the plugin is only installed for the Administrator user, so is only usable when I'm logged in as Administrator, which my IT support unit prohibits, because of the security risk of always being logged in as Administrator, even on personal machines. When I'm logged in as myself, Word does not have the plugin.
  • edited July 28, 2017
    I will add that, usually if there is some program requiring an Admin password to install it, I see a popup asking me to provide that Administrator login, and the installation works, and continues to work after I am no longer logged in as Administrator. In fact, such a popup appeared when I installed Zotero 5.0, and I provided the Admin login and password at that time.
  • I've tried reproducing this by disabling certain administrative permissions like regedit access (which is what the plugin uses), but it still installed fine.

    However, we've had a few users report problems like this since your report and it seems that going to Tools -> Add-ons, disabling and reenabling the extension fixes it. We're looking for a less awkward solution at the moment. Also manual installation instructions I've linked to above should work.
  • edited July 28, 2017
    I tried Tools -> Add-ons, disabling (and restarting Zotero) and reenabling (and restarting Zotero), then going back to Preferences -> Cite -> Word Processors, and hitting the Install button again, but once more, nothing happened, and Word still has no Zotero tab.
  • Should Word be closed or open while I am doing the above process?
  • That should not matter, but if it does not work, then I'm afraid for now you'll have to fall back to manual installation instructions.
  • And now, I tried it again, making sure that Word was closed the whole time. I got an "Installation was successful" popup. Then opened Word Zotero. :( I looked under Add-Ins in Word, and I saw that Zotero.dotm was listed as an active application add-in, but I saw no other sign of Zotero in Word.
  • Okay, that's a good sign. Zotero Ribbon Tab might not appear because of restrictive Macro permissions in Office. You should look in Word Options -> Trust Centre and see what Macro permissions are set.
  • Macro Settings are:

    Disable all macros except digitally signed macros.

    Is Zotero a digitally signed macro?
  • Zotero macros are not digitally signed. There should be an Add-ins section in the Trust Centre. Require Application Add-ins to be signed by a Trusted Publisher should be unticked if you want Zotero to work.
  • edited July 28, 2017
    My Trust Center does have an Add-Ins section, and in my case, the box "Require Application Add-ins to be signed by Trusted Publisher" is already unticked.

    Under Macro Settings, I could choose "Enable all macros (not recommended; potentially dangerous code can run)." But my IT support folks, and apparently, also Microsoft, frown on that setting. I am in fact unable to make that selection, even.
  • I should add that the non-Word aspects of Zotero work fine for me, including the browser add-in for Firefox that I installed. It's just the Word piece that doesn't function. However, the Word piece being un-installable for those of us following our institution's security best practices is going to be a problem.
  • So, the only way I can install Zotero's Word plugin on my workplace computer is to do something my IT department regards as unsafe and that Microsoft does not recommend, which is enable all macros? Is that accurate?
  • Oh, also - I followed the manual installation instructions, and did copy the .dotm file into Word's STARTUP folder...but I still don't see a Zotero menu when I restart Word.
  • If "Require Application Add-ins to be signed by Trusted Publisher", then there's something else going on. If you enable the developer tab and go into Developer Tab -> Add-ins, is Zotero.dotm listed? Do you see Zotero macros under Macros menu?
  • Turns out, in my part of the university, and possibly also in other parts, all macro functions are disabled for our office computers, unless they are signed locally. So I assume this kills the Word add-in to Zotero for MU?
  • Signed locally? So even if the plugin was signed with a legitimate code-signing certificate (which we're not really planning to do but we could consider it), that wouldn't work for you?
  • Is other software affected this way? Are people not able to use word processor plugins from other citation managers?
  • I don't know. I don't have any other citation managers installed. I'll ask my IT folks about that signing bit in the email I'm writing them now.
  • Oh, and in the Developer tab in Word, Zotero.dotm is indeed listed.
  • Is it listed and checked? Do Zotero Macros appear in Developer -> Macros?
  • Yes, listed and checked.
    Yes, the following appear under Developer -> Macros:
  • (but there's still no Zotero ribbon tab or Zotero buttons)
  • Right. Well, that's very weird, but I've just tested with Word 2013 and can confirm that it does not respect the "Require Application Add-ins to be signed by Trusted Publisher" checkbox like it does in Word 2016 so that's likely what you're seeing. We don't currently sign our extensions, but as Dan commented above, we will consider this.

    For the time being your options are upgrading to Word 2016 or reducing the Trust-Centre setting to Disable macros with notification and then click "Enable Content" on the notification that you will get when restarting Word.
  • edited August 4, 2017
    I did have 2013. So that I can teach my class on Tuesday, my IT professional upgraded me to Word 2016 AND enabled macros on my individual machine. But after I teach on Tuesday, he will re-disable the macros, and see if Zotero's Word add-in will still work. Stay tuned...
  • edited August 10, 2017
    I solved the absent ribbon problem in Word 2013, at least on my computer. I use Zotero standalone. Word needs a template to make a ribbon for Zotero. The template is in zotero.dotm. Word just needs to be shown where zotero.dotm resides.
    In Word, go to File -> Options -> Add-Ins. The last line has a drop down list that usually says "COM Add-Ins". Select "Templates" from the dropdown menu. Click the GO button.
    Zotero.dotm needs to be added to the "Global templates and and add-ins" box. Click "Add". I browsed over to the Zotero installation and found zotero.dotm. Once it was chosen the Open button changes to OK. Click OK. Word now reads the Zotero template. (You can also copy zotero.dotm into the Word files, but that is unnecessary.
    Zotero.dotm can be found at Systems(x86) ->Zotero ->Extensions -> ->install.
    I hope this helps.

Sign In or Register to comment.