Can't install LibreOffice Plugin

Setup : a small Windows 10/64 machine, updated to "Creators' upgrade" in order to install WSL and Sagemath, emacs and LaTeX on top of that (successfully, successfully tested).

Installed Zotero 5.0 with no problem. (Slow) synchronization to my Zotero account successful.

Installed LibreOffice 5.2.7.

First attempt to install the LibreOffice plugin via the "cite" panet of Zotero preferences : Zotero asks for a JRE.

Installed JRE, pointed to it in LibreOffice "Advanced" panel of LibreOffice options.

Second attempt to install LibreOffice (still via the "Cite" panel of Zotero preferences) : same problem : Zotero asks for a JRE (which now exists).

Same attempt after rebooting Windows : same result.

I'm stuck. Should I attempt to download the .xpi and install it directly in LibreOffice ?
  • .xpi is not for LibreOffice but for Firefox. In LibreOffice is important which version 32/64 bit you use for both applications (LO and JRE). These have to be the same. If you have 32b LO then must have 32b JRE. If the LO is 64b then you have to use 64b of JRE.
  • OK. I'll check that. Thanks a lot !

    Nice trap, BTW...
  • [ Later ] No such luck.

    I checked : Indeed, I had Java 64-bits and LO 32-bits. Since both Chrome and Firefow on my machine are 64-bits version, I choose to go in the same direction.

    I uninstalled LO 32-bits, installed LO 64-bits, pointed it to Java 64-bits. Then I tried to install the LO plugin : Zotero still wants a JRE...

    BTW : Zotero itself seems to be a 32-bits Windows app (it is installed on C:\Program Files(x86)) and there does not seem to exist a 64-bits version. Could it be the problem ?

    Suggestions ?
  • I think no, but a am not fully sure. On another hand, I use LO and JRE in 32b version (FF and Chrome in 64b) and all work OK.
  • @charpent sorry about that, I think 64-bits JRE detection on Windows is a bit buggy. In the meantime you can perform manual installation
  • edited July 19, 2017
    "@charpent sorry about that, I think 64-bits JRE detection on Windows is a bit buggy."

    Really ? ;-]

    "In the meantime you can perform manual installation"

    That should be documented with big fat pointers pon the relevant most-accessed pages...

    One more data point : I uninstalled LO 64-bits, installed Java 32-bits and LO 32 bits (NB : didn't uninstall Java 64-bits !), pointed it to the correct java, and, at least, was able to install the LO plugin "the official way".

    I'll try to revert to 64-bits LO and see if I can install the LibreOffice plugin, either as recommended or manually. Stay tuned.

  • One more data point : after uninstalling LO 32-bits and re-installing LO 64-bits, I saw that it pointed to the correct Java (64-bits). Zotero was then able to reinstall the LO plugin as recommended.

    Note that I didn't wipe the "App Data" directory(ies ?). Also, I had both Java 32-bits and Java 64-bits installed.

    It's a bit too much Windows black magic for my (admittedly Linux-biased) taste...

    Thank you to all for the (much needed) help ! And back to work (w/ emacs, latex, bibtex and Better Bibtex, on a Linux machine that will stay at Zotero 4.29.something as long as Better Bibtex won't run on Zotero 5).

    Suggestion : Shouldn't exist a 64-bits Zotero version ?
Sign In or Register to comment.