Zotero 5.0 Gnome integration

first off: congratulations to all the developers for the fantastic work you've put into the new release!!

I'm very excited to put it to immediate use, but wonder if there is a way to fix a little issue regarding the integration into Gnome (3.18.5 on Ubuntu 16.04.2): while I do get a Zotero icon in the launcher, I seem to be unable to add it to the launcher permanently. Right-clicking the icon in the launcher doesn't provide the usual mini-menu.
Also when I type "Zotero" in the search field in the activities overview I only get the Zotero folder. So in effect to start it I have to open the folder and click on Zotero there. (I want to add that I ran the set_launcher_icon script and symlinked zoter.desktop.)
  • second try :-)
  • edited August 10, 2017
    So you've symlinked zotero.desktop to ~/.local/share/applications, correct? Have you tried moving the .desktop file there instead of symlinking?

    This really should work without hiccup and if it doesn't, it indicated a more general problem with .desktop file recognition, like wrong permissions or such.
  • thanks a lot for this!
    I believe I did, but couldn't see any link in the ...applications folder. So I ran:
    ln ~/Zotero/zotero.desktop ~/.local/share/applications/
    I also re-ran the set_launcher_icon script.

    Now Zotero is found when I type it into the activities overview search field. But clicking on it does nothing.

    However, if I start it through Nautilus from my Zotero directory, I can now add it to my favorites and for now that is all I need, though in theory I think it should also work to start it via the activities overview search field.

    Again, thanks for your help!
  • well, hold on:
    it turns out I can add it to the favorites, but if I try to start it from there nothing happens, so I still have to start it from Nautilus
  • is ~/Zotero the directory where zotero-bin is located? You really shouldn't put the application files there, they're better of in /opt/zotero or similar. ~/Zotero is used to store your database, which you might want to keep hold of if you ever decide to remove Zotero itself. Otherwise, make sure that zotero.desktop you link to is in the same directory as zotero-bin and other application files
  • I think I had ~/Zotero for the application files themselves and then there's ~/.zotero which I thought would store the data files.

    In any case I now followed your recommendation and moved ~/Zotero into /opt
    I deleted the old link in ~/.local/share/applications and created a new link:
    ln /opt/zotero/zotero.desktop ~/.local/share/applications/
    I cd'ed into the new /opt/zotero and re-ran ./set_launcher_icon

    But not much has changed. I can start Zotero from Nautilus. An application search in the activities overview will find Zotero (but now won't display the actual icon as it did before, just a grey square where the icon should be), and clicking on it won't start the program.
  • You need to move the actual application files to /opt/zotero, not just the desktop file. Perhaps the easiest thing to do now is to backup the current ~/Zotero directory (by renaming to say ~/Zotero_bak, create a new ~/Zotero directory and place only zotero.sqlite and storage folders from ~/Zotero_bak. Then download Zotero from the website and extract the files in /opt/zotero, run ./set_launcher_icon and see if that works.
  • I think I moved the folder with the applications files (~/Zotero) to /opt and left the folder with the database (~/.zotero) in my home directory. Either way, I now renamed them both as you suggested, downloaded Zotero into /opt, extracted the files, rant set_launcher_icon. If I now click on the icon in nautilus, I get "Your Zotero profile cannot be loaded. It may be missing or inaccessible."
  • edited August 11, 2017
    Files under ~/.zotero should stay there, that's where Zotero stores profile information. Zotero data is, however, stored at ~/Zotero by default. Under ~/.zotero you should have a dir named something like [randomstring].default and under ~/Zotero you should at least have zotero.sqlite and the storage dir (there might be more stuff there).

    Make sure files and folders under ~/Zotero and ~/.zotero are owned by your user and have the correct permissions. You can change ownership by running sudo chown -R $USER:$USER ~/Zotero ~/.zotero from the terminal

    Does the application launcher item for Zotero work now (even if it launches with the profile permissions error)?
  • I think I start to get confused now.
    I have /opt/Zotero which contains the newly unpacked tar files. There is no zotero.sqlite there
    I have ~/.zotero. There's a storage.sqlite there. But no zotero.sqlite
    I don't have ~/Zotero anymore
    I ran sudo chown -R $USER:$USER /opt/Zotero ~/.zotero
    I ran sudo ln /opt/Zotero/zotero.desktop ~/.local/share/applications/
    I cd'ed into /opt/Zotero and ran sudo ./set_launcher_icon

    The result is the same as before: I can start Zotero only from Nautilus. In the activities overview it now finds Zotero (but doesn't display the correct icon), but clicking on it does nothing.
  • 1) /opt/Zotero is your Zotero program directory — that's just the extracted tarball files, and the location is entirely up to you. ~/.zotero (by which I assume you mean ~/.zotero/Profiles/<randomstring>) is your Zotero profile directory, containing settings. ~/Zotero is the default Zotero data directory, containing your Zotero library data.

    2) Probably not the issue, but you're using a hard link for the zotero.desktop file. You should use a symlink (ln -s) instead, and you shouldn't use sudo, because you're creating a symlink in your own home directory.

    3) If files within /opt/Zotero are owned by your user, don't use sudo to run set_launcher_icon.

    4) When you run set_launcher_icon, it should modify zotero.desktop to reflect the current path to the icon. You can verify that.

    It's not clear to me what happens now if you double-click either 'zotero' (the executable) or 'Zotero' (the desktop file) in /opt/Zotero.
  • oh my, it seems like it works now !!
    #2 did the trick. I deleted the old link and ran in my home directory without sudo: ln -s /opt/Zotero/zotero.desktop ~/.local/share/applications/

    Thank you tons for staying with me so patiently, I really appreciate it!
Sign In or Register to comment.