[5.0.4] Sync failure Report ID 2083404831

I just updated to 5.0.4 from 4.x . I have a sync error. The red icon says:

An error occurred during syncing:

Error(s) encountered during statement execution: cannot start a transaction within a transaction

Report ID 2083404831

Chrome: Version 59.0.3071.115 (Official Build) (64-bit)

[Also, Items aren't saving to My Library either, but i'll save that for another post.]
  • I assume the answer is yes, but you've tried restarting Zotero, right?
  • [JavaScript Error: "[Exception... "Component returned failure code: 0x8052000e (NS_ERROR_FILE_IS_LOCKED) [mozIStorageService.backupDatabaseFile]" nsresult: "0x8052000e (NS_ERROR_FILE_IS_LOCKED)" location: "JS frame :: chrome://zotero/content/xpcom/db.js :: Zotero.DBConnection.prototype.backupDatabase< :: line 1043" data: no]"]
    If this happens after a restart, we'd want to see a Debug ID for a startup through the error using the "Enable after startup" option.

    (And the save error is quite likely from the same problem.)
  • Oh man, If i had a nickel for every time I've told my wife: "It's not a problem till it's a problem after you reboot..."

    No, I didn't restart Z. I restarted Chrome, but apparently that doesn't count! :)

    All is well. Carry on.

    Thanks.
  • Shouldn't happen of course, so let us know if you see it again.
  • edited 4 days ago
    It happened again. The same sync error. Nothing would save to Z.
    Report ID: 1074869233

    And, again, a restart "fixed" it. I had enabled Debug upon restart :
    The Debug ID is D1117872726, but that will probably only show that everything is fine, because it is now, right?

    The items that wouldn't save, came in automatically upon restart.

    Everything is fine now, but you wanted to know if I saw it again.

    It occurred when when I woke my sleeping Win10 machine this morning which had Z still running. Everything was fine last night.

    Hope that helps.

    Edit: I tried to induce the error by putting my computer to sleep, then waking it up, but everything is still fine.
Sign In or Register to comment.