PDF not saving--Zotero for Firefox

I am running Zotero ( for Firefox on a PC and it is no longer grabbing PDFs when I save citations. I have chosen the 'automatically attach associated PDFs and other files when saving items' option in my general preferences and have previously never experienced this issue.

Two examples of articles I tried to save:

In the Taylor & Francis database:

Stearns, C. (2016). Responsive Classroom?: a critique of a social emotional learning program. Critical Studies in Education, 57(3), 330-341.


In ProQuest:

Arslan, S., & Demirtas, Z. (2016). SOCIAL EMOTIONAL LEARNING AND CRITICAL THINKING DISPOSITION. Studia Psychologica, 58(4), 276-285.

The first example allows me to save citation info/snapshot. In the second example Zotero seems to interpret it as a webpage and it will not collect citation info, just take the snapshot.

Here's a report ID if helpful: 228691070.

Any suggestions on how to restore this functionality?

  • I am experiencing the exact same thing currently too
  • could we get the URL exactly as you see it for the first one and the ProQuest permalink for the second one?

    bcalderflynn -- as in on specifically those two pages?
  • Ah yes -- proxies that use hyphens (note the www-tandfonline-com) will only work with Zotero 5.0. I recommend you update. See https://www.zotero.org/blog/zotero-5-0/
  • Thanks, Adam! I just looked through the documentation and updated to Zotero 5.0 with the Firefox connector.

    This solved the problem in ProQuest but I'm still experiencing the same issue in Taylor and Francis--only saving citation info/snapshot. I tested both when I was viewing the page with the abstract and PDF link and also tested it after I had opened the PDF in my browser, but each time it had the same result. Do you think this is an isolated issue with T&F or is there something else I should try?

    Thanks again for the speedy responses.
  • When you hover over the Save to Zotero icon while on that page -- what does it say?
  • When I hover it says 'Save to Zotero (Atypon Journals)'.

    When I right click and bring up additional options, these are the available choices:
    *Save to Zotero (Atypon Journals)
    *Save to Zotero (Embedded Metadata)
    *Save to Zotero (DOI)
    *Save to Zotero (Web page with snapshot)
    *Save to Zotero (Web page without snapshot)
  • It doesn't recognize this correctly then. With the right translator (it would say Taylor and Francis & NEJM) this would work. I'll need to investigate. Curious, when you put
    into your URL bar and press return, does Firefox automatically change the URL to the one above?
  • Interesting--when i put the URL you provided into the address bar it takes me to the article outside of our proxy and then the translator seems to recognize the document correctly. When I go outside the proxy and hover over the icon it says: 'Save to Zotero (Taylor and Francis + NEJM).

    I added a connector both to Firefox and Chrome and it's the same in each case. Going through the proxy, it says 'Atypon' but going through the link you provided it says 'T&F'.

    Do you think the issue could stem from the hyphens in the proxy? It seems that the unproxied URL removes hyphens/spacing. We have hosted EZ Proxy but I could contact them to see if there is a difference.
  • The connectors should be able to recognize and handle the hyphenated EZ Proxy URLs. I'll have to experiment & see what's going once I'm off campus.

    Do you have automatic proxy redirection turned on in the connectors? To check in Chrome, paste

    into your Chrome bar and press enter.
  • The automatic proxy redirection is turned on in Chrome but it's still recognizing the work as 'Atypon Journals' instead of T&F.

    Thanks for helping!
  • @araefielding seems like you have a hyphenated proxied URL even for a non-HTTPS scheme, which the Connector does not expect by default. See if T&F translator gets detected after going to Connector Preferences -> Proxies -> http://%h.fgul.idm.oclc.org/%p and checking "Automatically convert hyphens to dots in proxied hostnames"
  • @adomasven thanks for this suggestion. I just tried updating these preferences, but when I went back to the work in T&F, the connector only interpreted it as a webpage. My only options were to save to Zotero as a webpage with/without a snapshot, but it no longer seemed to recognize that I was viewing an article with citation metadata.

    I de-selected the 'automatically convert hyphens to dots...' and re-tested and it reverted back to seeing an article but offering the same set of options I listed above, beginning with 'Atypon Journals'.

    Thank You!
  • Update to 5.0.10 and see if T&F is detected correctly.
Sign In or Register to comment.