Upgrade to v5 lost site-specific export settings

I just upgraded to 5.0.1. from v4. Most things seem to be working, but my site-specific export settings are no longer present.

And there is no obvious dialogue option to recreate them.

FWIW, I use Firefox (v. 54.0.1) under Win 10.
  • These are indeed not currently available. The problem is that we can't actually tell that you're dragging to a webpage, so what Zotero for Firefox was doing was generating the content based on the address bar when you started the drag from Zotero, and there's no longer an address bar in Zotero.

    We could in theory still support these via the Connectors, though it'd be a little awkward — basically, whenever a tab became active in a browser with the Connector installed, it would ping the Zotero app, and if you then started a drag (either before another page became active or some short timeout occurred), it would use the site-specific format. So most of the time it would do what you wanted, and maybe very occasionally you would be on Wikipedia and switch back to Zotero and try to drag somewhere else and end up with Wikipedia Citation Templates by accident. (But that could've happened in Zotero for Firefox too.)
  • So what is, for me, one of the most useful aspects of Zotero has been removed *and its not even mentioned in the change log*?!?
  • It only ever existed in the Firefox version -- surely you don't expect the Changelog to list every difference between the two?
  • edited July 11, 2017
    I would have expected it to mention such a /significant/ change; especially the removal of functionality.
  • I think you're probably one of 15 people in the world who used this (aiming high here). I've perhaps interacted with more Zotero users than anyone in the world. I have never gotten a question, complaint, or compliment about this feature. Andy, you've been around in tech circles enough to know that "but it's important to me" is a silly argument.

    It's also just not a _change_: this didn't change from Standalone 4.0 to Standalone 5.0. It's a side effect of Zotero deprecating the Firefox version.
  • It take five clicks to change export format; and five to switch back again.

    The loss of the per-site functionality could perhaps be mitigated by a toggle-switch on Zotero's own tool bar
  • [my last post was made before I saw Adam's last post]

    I have *personally* taught more than 15 people to use this feature.

    The number of people in audiences for events where I have described its use is well more than ten times that.

    I have personally collaborated with a developer to build a script to export in a Wikidata-compatible format specifically to make use of this feature.

    The use of this feature is described and encouraged in documentation I have collaboratively written on Wikipedia, Wikidata and Wikispecies.
  • A Quick Copy submenu for faster format changing is planned, and we'll see what we can do to add the site-specific settings to the connectors.

    (For what it's worth, I've actually always been rather proud of this feature, but I would agree with adamsmith's assessment that it's used by very few people, and we never even considered adding it to Standalone before 5.0. While we did try to achieve feature parity between Zotero for Firefox and the connectors on nearly every feature for 5.0, this one was barely on our radar. But the feature was essentially designed for Wikipedia, so I guess it's not surprising that it has some adherents there.)
  • Thank you, dstillman.
  • Personally, I like the QuickCopy also and build some stuff above it (which was already mentioned above). The site specific export options can become quite useful like in the case of Wikipedia but maybe also with more online text writing tools. I appreciate the efforts to try to continue something here.

    For the meantime: As far as a I know also Zutilo has some additional functionalities with QuickCopy, but I am not sure if this extension is 5.0 ready.
  • Zutilo was the first extension to be 5.0 ready, though there was a recent bug report.
  • @pigsonthewing : Yes, Zutilo could help here. You can switch from one export format to another with one key.

    From https://github.com/willsALMANJ/Zutilo/blob/master/docs/COMMANDS.md :
    Item menu functions […]
    QuickCopy items: Copy selected items to the clipboard using the "Default output format" specified in the "Export" section of Zotero's preferences. There are also two alternative QuickCopy items (labeled "alt 1" and "alt 2"). These items will copy to the clipboard using alternative export translators. To select the translators used by these functions, the corresponding preferences extensions.zutilo.quickcopy_alt1 and extensions.zutilo.quickcopy_alt2 must be set in about:config. Each preference should be set to whatever appears in about:config for the export.quickCopy.setting preference when the desired translator is set as the "Default output format" in Zotero's preferences.
  • Yes, it looks like I can use Zutilo as a work-around, thank you.

    However it presents too high a barrier to entry for some of the people I work with.
  • edited July 19, 2017
    OK, we've restored site-specific Quick Copy for the next version, 5.0.5, which should be out in the next day or two. It'll use the URL from the last tab loaded or switched to in any open browser with the Zotero Connector installed (no matter where you're dragging, but that was the case in Zotero for Firefox too).
  • That's great news! Thank you.
  • This is available now in Zotero 5.0.5 and Zotero Connector 5.0.10.
  • Working nicely, thank you - I'm impressed that it picked up my settings from v4.
  • I had to delete the https:// and http:// protocols in my settings. Now, it works nicely again. Thank you very much!
  • It's no longer working for me :-(

    My default is to export as "Wikidata QuickStatements", and I have a domain-specific setting for "wikipedia.org" to use "Wikipedia Citation templates". The latter fails, and exports in the default

  • This is working for me. Can you provide a Report ID from Zotero? Is saving from the connector (from the same browser you're using to visit Wikipedia) working for you? Have you tried restarting Zotero and the browser?
  • Some time ago I saw some Zotero errors like "Could not load settings for Export", but after some time and several updates and restarts, it seems to work fine now for me.
  • Apologies; this completely slipped my mind.

    It's working OK, now.

    But yes, I had tried several restarts, and resets of the rules, and even experienced the problem in different 5.0.N versions.
  • The site-specific settings didn't work anymore for me since the v5.
    I use Zotero 5.0.34. When I drag/drop a reference in the website mentioned in the site-specific settings, Zotero use the default format (Chicago manual of style...) and not the one specified for my website (RIS).
    Many thanks in advance for any good idea to solve my problem.
  • I can reproduce this. It looks like, with the latest version of the connector, it will work in some tabs but not others. We'll investigate. Thanks for reporting.
  • This should be fixed in the latest version of the Zotero Connector, 5.0.34.
  • Great !
    It is always a pleasure to post on this forum and to get answers and solutions.
    Many thanks.
  • My Zotero connector for Firefox is now 5.0.34 (automatically updated)
    Site-specific settings work right now.
    Many thanks for this correction.
  • Hello,
    With the new version 5.0.35 of the Zotero connector for Firefox:
    - site-specific settings don't work anymore
    - and the RIS format don't work as default format for rapid copy
    It seems that anyone else report this default...

  • It's working for me with Zotero Connector 5.0.35 for Firefox and Zotero

    Can you provide a Debug ID from Zotero for 1) triggering Quick Copy on a non-Wikipedia page, 2) switching to a Wikipedia page, and 3) triggering Quick Copy again?
  • Hello Dan,
    I verified my versions :
    Zotero connector : 5.0.35

    I began the Debug ID process and stopped it because it is working well now.
    I have had trouble yesterday, but no time to report, and have retested today before writing my post.
    Really sorry fot that.

Sign In or Register to comment.