Now available: Zotero 5.0

  • No, not currently, sorry.
  • But there are plans to add that feature to the connectors in the near future.
  • right. fingers crossed z4 for firefox will survive until the functionality becomes available in z5. it's quite a handy option to be able to quickly pool infos/research together around an object. thanks for your support.
  • This is the first of two comments because they're really separate issues.

    Updated Z4 -> Z5 last night on one of my computers. Most things went smoothly. But this morning when I started up Z5 I'm getting an error message: "This Zotero database requires Zotero 5.0.17 or later. Current version: Please upgrade to the latest version from"

    But then pressing the "Check for Update" button yields: "No Updates Found. Zotero is up to date." Moreover, Zotero > About Zotero yields, "5.0.17" as the current version.

    Let me guess: this behavior is because Firefox is running when I start Zotero, and Firefox still has Z4 installed. If so, then what's the best way of addressing this problem? Will disabling the Zotero plugin in FF be sufficient? Or does one have to uninstall it completely?

    Disabling the plugin is preferable, since this preserves some of the older functionality (as Hadzi has been requesting -- in my case it would be Better Bib(La)Tex) just in case it's needed.

    If having FF running is not the cause and you know why these error messages pop up, please explain and suggest the remedy.

  • edited August 31, 2017
    After installing Z5, Tools > Add-ons > Extensions opens the Add-ons Manager, which lists the installed add-ons and distinguishes those that are compatible with Z5 from those that are not.

    In my case, these six were not:

    * ZotFile (see below #1)
    * RTF/ODF Scan for Zotero (see below #2)
    * ZoteRename
    * Zotero Better Bib(La)Tex (see below #3)
    * Zotero Scholar Citations (see below #1)
    * Zotero-to-BibDesk auto-import utility

    I hope the following information is helpful.

    #1: Installing updates to ZotFile and Zotero Scholar Citations solved the problem.
    #2: Instructions for replacing RTF/ODF Scan with something that works in Z5 can be found in this thread: Especially see Adam Smith's first post in the thread.
    #3: Work on a new version of BBT is progressing. See emilianoheyns's first post in the thread mentioned in #2 above for links to the latest updates on BBT development. But apparently Z5 completely changes the way information is stored for individual items in Zotero. So it's not clear that a completely backward-compatible BBT is even possible in Z5, and developing something even close will require heavy lifting. So don't count on this anytime soon.

    This leaves ZoteRename and Zotero-to-BibDesk auto-import as the remaining mystery meat. It's been quite a while since I installed these extensions, and my memory of them is a bit rusty. ZoteRename is not even listed on Zotero's Plugin list (, and for BibDesk the only entry similar to what's shown in the Add-ons manager is Zot2Bib (the description of which implies it has identical functionality to the disabled plugin; in fact, the two may be identical, but I'm just going by the name listed in the Add-ons Manager).

    The web site for Zot2Bib ( makes no mention of Z5, but I suspect many plugin developers have not yet updated their support sites for Z5. More ominously, its GitHub site ( shows the most recent update was three years ago.

    So, do you know the status of ZoteRename or Zotero-to-BibDesk in relation to Z5?
    Have you any experience (or, even better, success) making them work with Z5? Do you know of functional substitutes?
  • Completely disappointed in the loss of the Firefox integration. Using the Standalone to get files into my library is a pain. No longer get the "Save to Zotero" option when downloading. Huge loss in functionality. Need to do better!
  • edited September 1, 2017
    @kudane As has been said here numerous times, Zotero didn’t have a choice—Mozilla has removed the required functionality from Firefox. There are a variety of integrated methods to import files to Zotero that are as convenient in my experience as the option in the download dialog.

    @marsh (1) Upgrade your firerfox plug-in to the new version of the connector from

    @marsh (2) I’ve never heard of ZoteRename. Does it just rename attachment files? If so, Zotfile provides that functionality and I would recommend just not installing ZoteRename.

    I don’t believe Zot2Bib is still being updated. I would recommend just waiting for BetterBibTeX to be updated, which appears to be coming along well.
  • So far, I really like 5.0! However, I just tried to create a bibliography from a saved search, and it doesn't work. I don't get the pop up screen to select the citation style etc. If I try to create a bibliography from my entire collection it does work, so it is only a problem for the saved search. Who can help me solve this problem?
  • @Paulineo How exactly are you trying to make a bibliography?

    @dstillman Can we split this to a new thread?
  • @bwiernik I right-click on my saved search and select "create bibliography from saved search"
  • Okay, that does appear to be broken for me too on the latest 5.0 beta. Until it's fixed, you can just click on an item in the Saved Search results, select all (Ctrl/Cmd+A), then right-click and choose Create Bibliography from Items.
  • A comment: opening my 15,000-item database in 5.0 takes about 30 seconds, which is much longer than in previous versions. After the initial opening things are pretty quick, so it's not a big problem. But is it expected to take that long, or is there a problem with my particular database?
  • From what I gather, ~30secs on startup for a large-ish database is about normal right now. They're still working on speeding this up, but as you say, startup time isn't the biggest issue.
  • update from the adventures with standalone.

    for almost a week zotero has been running without giving problems, until this morning, when z5 required to restart.

    @zotero devs, could you please check if this is a serious issue, i send the report with id: 1194315557.

    basically the message was simply saying that there was an error & to restart zotero standalone. i did so, & things work again, just wondering if there's anything that can be done about it?
  • edited September 3, 2017
    Thank you for the hard work moving to 5.0, it shows! We used to be able to add an item with an attached note directly from Firefox (clipping part of an article, for example) and I've been looking all over for that feature in the new 5.0. Is it somewhere I haven't found, and if not, I'd like to request it as a feature to add back. Thank you!
  • That feature doesn’t currently exist in the connectors, but Dan has mentioned that it will likely return in a future update to the browser connectors.
  • Thanks for all the feedback and bug reports. Now that 5.0 has been out for a while, I'm going to close this thread. Please start new threads for any remaining issues.

    And just to mention it one more time, if you're looking for the full Zotero pane in Firefox, see the blog post where we explain how to use Zotero going forward and why the change had to be made.
This discussion has been closed.