Zotero Connector is unable to communicate to Standalone-Version


today I found an issue realted to Zotero Standalone, Zotero Connector and Adblock Plus. I've reported the Issue with Report ID D1227045452.

As far I detected, the problem is my Installation of Adblock Plus Version 2.9.1. Is it deactivated, Zotero Connector transfers the data properly.
Is it activated, at the, I can see "Endpoint does not support method".

I tried to whitelist the URLs

and rebooted Firefox.

At AdBlock counts hits, but although it's whitelisted, Zotero Connector tells me that "Zotero is offline".

Does anyone have an idea how I can solve this conflict between AdBlock Plus and Zotero Connector?

Thank you in advance!
  • One thing to try is to ask on Adblock Plus forums. There will not be a workaround from Zotero for this and there is no reason why Adblock Plus should block extension requests to localhost.
  • Thanks, I will try that.

    Maybe I should tell, that two days ago AdBlock Plus and Zotero worked properly together and the issue occurs only since this morning.
  • I could solve the problem.
    For your interrest:

    Adblock has filter lists, which you can subscribe to. One of them, called EasyList, had an update and there was a rule


    that caused the error. Deactivated this single rule and all worked how it should be.
  • Thanks for the solution. It worked for me as well.
  • @caddi91 did you report this issue on Adblock Plus forums as suggested?
  • You're a genius for finding that solution!!!
  • Indeed you are a genius!! I struggled for 2 hours to get rid of this connection problem before finding your post!

    I cannot even imagine how you found that this particular line was messing up with zotero.
Sign In or Register to comment.