Zotero starts but there is no visible instance

When starting Zotero on Windows 10, sometimes nothing happens. When I check the Task Manager or Process Explorer, I can see an instance running, but there is no visible window. Sometimes this window appears after a couple of minutes, but often I have to kill the Zotero process and restart it.

Any idea what is going on here?
  • What version Zotero do you use? You can try to logging the debug output after start and post here the debug ID - see https://www.zotero.org/support/debug_output
  • Version:

    I've turned on the debugger, but it happens rather unpredictably, so it might take a while.
  • Debug ID: D1196347691

    What happened:
    - Started computer
    - Started Zotero; Instance of Zotero visible in Process Explorer, but no visible Window
    - Start other programs; they start up fine
    - Visible empty window around +2 minutes; "Not responding"
    - Zotero starts normally around +4 minutes

    Is that helpful or do you need more?
  • Yeah, database access is extraordinarily slow in that debug output. Start by disabling BBT and any other plugins to make sure those aren't contributing.

    Did this start recently? Have you added a large number of items recently (including in the trash)? Have you tried restarting your computer? Is this on a network share or a local hard drive?
  • This one was with all plugins disabled.
    Debug ID: D1442592439

    - Started computer
    - Started Zotero
    - Window appears at +1 minute, with collections pane (left) visible, but items still loading in center pane; "Not responding)
    - Zotero fully functional at +3 minutes

    Your questions:
    - Did this start recently? No, has been going on for some while (couple of months, I'd say)
    - Have you added a large number of items recently (including in the trash)? Not recently, but the database is pretty large (12183 items with quite some collections and subcollections).
    - Have you tried restarting your computer? Yes. This sometimes changes things, and sometimes not. The two debug IDs I sent are both immediately after startup. The problem occurs inconsistently at various stages after startup. Startup time for Zotero varies between 10 sec and 5+ min.
    - Is this on a network share or a local hard drive? Local HD
  • How old is this computer? Even with a HDD, not an SSD, these times just seem way too slow — you're seeing times of half a second or more for database queries that do no work, and then others that are taking full minutes.

    Have you checked with a task manager to make sure your computer and hard drive are otherwise completely idle? Have you tried temporarily disabling security software?

    It looks like this is running on D:, not C:? Is there a difference between those? Have you tried moving your data directory to C:?

    It's unlikely to speed things up (and possibly the opposite), but as a first step you could install the Zotero 5.0 Beta (which will be released as final very soon), which is built on a newer framework that might avoid some strange interaction that's slowing things down. (Just be sure to switch back to 5.0 Final once it's out.)
  • (Oh, though not sure if BBT works with 5.0 yet. I think possibly not. If you stay on 4.0, you might want to disable auto-sync temporarily before moving your data directory around, since it's a bit easier to get the steps mixed up and kick off an accidental full sync.)
  • - How old is computer? - 2015, so not that terribly old. Intel Core i7, 8GB RAM, 1TB HDD at 5400rpm. Not the fastest hard disk, but it does work with Adobe Premiere, so I hope it's reasonable to assume Zotero shouldn't be a problem.

    - CPU and HD load - I will look more carefully next time, but I don't remember seeing any CPU hogging or other unusual resource use last time. Will get back later on that.

    - Zotero running on D: rather than C: - Those are two partitions on the same disk. Do you think this could have something to do with it? (I remember simultaneously accessing two partitions sometimes slows things down.) For logistical reasons (size restrictions, work vs. home, automatic backup routines) I'd prefer not move anything off D if it can be avoided.

    - Zotero 5.0 beta: New toys! Just installed it. I'm not sure it solved this specific problem, but my general impression is that Zotero has become a lot more responsive. Will get back if the problem resurfaces.
Sign In or Register to comment.