zotero Chrome plugin not working for google scholar

When I attempt to save citations to my Zotero from google scholar using Chrome zotero plugin, I receive an error message:“An error occurred while saving this item. See Troubleshooting Translator Issues for more information.” I click the link,but it cannot solve anything.
I'm using proxy to get logged in google scholar.
When I go to the Zotero Connector in extensions and click "options", I see a a "report errors" section with many instances of the following:
[JavaScript Error: "Cannot read property 'url' of undefined" {file: "chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/background.js" line: 580}]
When I click the "Report error" below that, I get a report number :1617127455, 1062656931.
I submit twice, so I get two report numbers.
Thanks for you help.
  • Try resetting translators from the Advanced tab of Connector Preferences, then try again.
  • I've had the same issue, and have tried resetting translators in this manner without success. I'm not using a proxy, am using Zotero Standalone on Google Chrome. I only have the problem with Google Scholar - I'm able to download meta data from all other sites. Report ID: 1619752393.
  • could you click on "Cite" under a google scholar entry and then on "BibTeX" at the bottom of that window. Does that work?
  • That still works for me yes.
  • That should really work then
    Some more questions:
    And Zotero consistently fails to import still?
    Could we get a URL of a google scholar search from which you're importing just in case?
    Could you try with all other Chrome extensions disabled?
    Do you have particularly strict privacy settings? I think Zotero may need to be allowed to set third party cookies for GS import to work.
  • Yes, I've had no success with the translator on Google Scholar for some time now. Normally I just go to the page where the sources is located, then it works fine, but it's quite a hassle when you want to get data for multiple sources simultaneously. Here's an example of a search, but the translator fails regardless of what I search for:


    I've now tried with all other extensions disabled and the problem persists. I've tried playing around with the privacy settings in Google Chrome as well, without success. Could the issue relate to my antivirus in some way? I'm using the free version of AVG.
  • I'd be surprised if this was AVG, but might be worth trying to disable that for a single save attempt for testing.

    Could we get a debug ID from the Chrome connector for trying to save a single item from the above linked search?
  • Thank you for your above answering.
    But the problem still there.
    I get a debug id , 1339533341, please check it.
    Thank you again.
  • Debug IDs start with D -- they're distinct from error reports
  • BibTeX not found. Got page with title "Sorry..."
  • The debug id is D672657549,
    The report id is 1639087784
  • Oh, this is also through a proxy. That shouldn't be necessary for Google Scholar. Remove scholar.google.com from your proxy entry in the connector preferences and try again from just scholar.google.com.
  • I have cancelled all proxies, and disable all options of proxy direction, but the problem is still there.
    The debug id is D1489654789
    The report id is 1789955371
  • And look at your address bar — you're still on a proxied page.
  • I am using off-campus proxy to visit resources.
    So that means I cannot use zotero in off-campus proxy.
    Thank you for your answering.
  • Zotero really works when I not use proxy.
    Just a little inconvenient.
    Using off-campus proxy to get paper, then not using proxy get cite information.
    But it works.
    Thank you for patient answering.
  • edited July 9, 2017
    So that means I cannot use zotero in off-campus proxy.
    No, that's not what it means. Zotero is designed to work with off-campus proxies, but Google Scholar isn't a gated site and it doesn't need to be used via a proxy — and the fact that you are may be the reason the requests Zotero makes to Google Scholar are being blocked (because all those requests would come from the proxy server's IP address, and Google Scholar actively blocks IP addresses that make too many requests). You can test this by trying to download BibTeX from the Google Scholar website while using it via the proxy. (If that works, there may be another issue here that we can look into.)

    So what I'm suggesting is to delete scholar.google.com from the proxy entry for your university's proxy server in the Zotero Connector preferences so that it doesn't try to redirect your requests to Google Scholar through the proxy and then to load Google Scholar directly yourself without going through the proxy, so that it just says scholar.google.com in the address bar.

    It's true that the links from Google Scholar to publisher sites won't then go through the proxy initially, but once you visit each publisher site through the proxy (which you can usually do quickly by appending the "library3…" to the domain), Zotero will learn those and start doing the redirection for you.

    In any case, even if you can't get this to work, you can still use Google Scholar via the proxy and save to Zotero just by clicking through to the publisher's site and saving from there. You'll usually get better data from the publisher's site anyway.
  • I finally understand throu your detailed answering.
    It really works even using off-campus proxy when I append the school domain in “Disable proxy redirection when my domain name contains” under the “Enable proxy redirection”. And Both options are checked.
    A lot of thanks.
  • Well, that's not what that option should do, though. That should only change things if you are currently on your university's network — it's to prevent you from being redirected through the proxy when you already have access to gated resources by virtue of being on campus.

    The thing that would've fixed it would be removing scholar.google.com from the list of proxied hosts and then connecting directly to Google Scholar (instead of going through your university's library website, which might send you through the proxy).
  • o.k. I will try.
Sign In or Register to comment.