PDF is not downloaded from proxied pages

edited June 14, 2017
I've tried import to the Zotero the article from https://link.springer.com.ezproxy.techlib.cz/article/10.1007/s11367-017-1327-6
Metadata are correct, but PDF version are not downloaded. Debug ID from connector is D19814278
I've tried it 6 times - I've tried reload page, restart the Chrome, set-up proxy in the Zotero Connector preference, save by Springer Link and embedded metadata translator.
  • is this to the 5.0 beta or to 4.0?
  • 5.0 beta.212
  • I've updated to Zotero beta.213 but the problem still persists
  • This seems to work for me with the same setup. Do you get the error cross for the PDF? Could you produce a Debug ID from the client?

    Anything weird about your setup? Are you on campus? Does it work if you disable the proxy feature in the connector completely?
  • edited June 15, 2017
    It still not works for me. I am in my office, we have no subscription to the Springer so I use subscription from National technology library (exproxy.techlib.cz).
    Another open access document from the same issue without proxy in the URL - https://link.springer.com/article/10.1007/s11367-016-1218-2 is downloaded correctly in the first attempt all other attempts are unsuccessful :(
    If I add the proxy in the URL (https://link.springer.com.ezproxy.techlib.cz/article/10.1007/s11367-016-1218-2) then the pdf document is not downloaded in all attempts.
    I've tried download proxied it with "Enable proxy redirection" checked and also with unchecked - no success.
    Debug ID for Zotero 5.0 is D1730220602

    EDIT: Yes, I get the error cross for the PDF
  • I'm confused — that debug output seems to show a successful download of the PDF.
  • All unsuccessful attempts from https://link.springer.com/article/10.1007/s11367-016-1218-2 were due to deleted items in the trash (sorry my fault I forgot to empty bin before next attempt)

    Here is Debug ID from successfull attempt (from https://link.springer.com/article/10.1007/s11367-016-1218-2):
    Zotero: D1471007248
    Zotero Connector: D1777137251

    Here is unsuccessful attempt (from https://link.springer.com.ezproxy.techlib.cz/article/10.1007/s11367-016-1218-2)
    Zotero: D1192924459
    Connector: D2080351984

    Can be it due to https? I see warnings message in the address bar that https://link.springer.com.ezproxy.techlib.cz/article/10.1007/s11367-016-1218-2 is not secured
  • "error opening PDF: […] Win error 2 during operation open on file […]" {file: "chrome://zotfile/content/pdfextract/toc.js" line: 14}]
    Disable ZotFile.
  • edited June 15, 2017
    Actually, while the error is showing up in ZotFile (and you should definitely disable it to test), it probably is that certificate error:
    link.springer.com.ezproxy.techlib.cz:443 uses an invalid security certificate.

    The certificate is only valid for the following names:
    *.ezproxy.techlib.cz, ezproxy.techlib.cz

    Error code: <a id="errorCode" title="SSL_ERROR_BAD_CERT_DOMAIN">SSL_ERROR_BAD_CERT_DOMAIN</a>
    techlib.cz's proxy server is using HTTPS, but current standards-compliant browsers won't accept a wildcard certificate (e.g., *.ezproxy.techlib.cz) across periods (e.g., link.springer.com.ezproxy.techlib.cz). Most browsers used to accept this, but they don't anymore, and as I understand it, institutions are now switching to a hyphen-based proxying mode (link-springer-com) to get around this. You could store an exception in Zotero (which presumably you already did in your browsers), but it'd be much better for them to fix this properly, since otherwise every user of theirs would have to whitelist the certificate in their browsers manually.
  • First test: disable ZotFile - no success
    Zotero Debug ID: D1461565011
    Connector: D1144094590
  • Copy exceptions in Zotero help. Thanks
Sign In or Register to comment.