Date mixed up in the type "document" in the German version

I just realized that there is a huge problem in the German version of Zotero. If you add a new document from the type "document" and you enter the date, Zotero is mixing up month and day!!
So for example if I'm entering the 1th of May 1963, it is 1.5.1963. Zotero is getting it in this document type wrong and is making 5.1.1963 out of it because it is interpreting it as May 1th, 1963!
  • edited 20 days ago
    Yes, this behaviour is not only in the German language. You have to check very carefully Zotero´s interpretation of the date in numeric form or use ISO 8601 format (YYYY-MM-DD) or use the textual form of a month. Unfortunately, Zotero uses American date format as default in situations when cannot be decided about the exact date.
    EDIT: @adomasven @dstillman it should be great if users can define default date format in the options.
  • edited 20 days ago
    Unfortunately, Zotero uses American date format as default in situations when cannot be decided about the exact date.
    This is incorrect. If you're using the German locale — i.e., if you see "Meine Bibliothek" in the top left — Zotero should properly parse "1.5.1963", with "d m y" appearing to the right and "1963-05-01" appearing when you hover over the field. I've just tested this now. (With a U.S. English OS locale, I do still see 6/5/2017 for today's date in the Date Added/Modified fields. I'm not sure if that happens if the OS locale is set to German, but it looks like it gets it right for those fields in the middle pane, so this should be fixable.)

    If you're not seeing the right locale in Zotero, you can adjust it. The upcoming Zotero 5.0 may be better at detecting the active locale used by the OS (currently available in the Mac and Linux beta builds).
  • Sorry, you are right. I am using US locale in Zotero 5 but I am still thinking in european date format. On other site, it should be great if I can setup the prefered date format independent on active locale.
  • @dstillman thank you for your answer. But unfortunately it doesn't work that easy, though. I see "Meine Bibliothek" in the top left, so that is not the problem. I just created a new "document". The date of the document is 1th of June 2016. I type that in the German way 1.6.2016. But Zotero is interpreting this as m.d.y. Also when I hover over the field, it says 2016-01-06, which is the 6th of January and not the 1th of June as intended.

    @LiborA if upgrading to Ver. 5.0 is fixing that problem, I'll go for that.
  • Yeah, so 5.0 might fix this, but the easiest thing to try for now is just setting the locale to 'de' manually and restarting Zotero. Let us know if that doesn't work.
Sign In or Register to comment.