Export with pdf attachments

I have been trying to export my reference library to use in another reference manager. The problem is that no matter what I do, pdf attachments aren't being imported in the other reference manager.

– I have tried to export to bibtex, RIS and Endnote XML (all with file export checkmarked).
– I have tried to import into Endnote, Papers, Mendeley and ReadCube.

Also, the exported folder contains some folders containing pdf's, but not all of them! -less than 20 of several hundred.

I think this indicates that Zotero export is broken.

Zotero 5.0-beta.203+898a1dc for Mac
  • That's quite odd. Have you made sure that you can open the files from within Zotero? Are those linked files (have a link icon on top of them) or attached files (show with the PDF icon)? Only attached files would export.

    Are the PDFs that _are_ exported into the folder also not imported into any of the other software?
  • I can open all files in Zotero just fines. They are not linked (well, a few, but most are PDF).

    None of the few exported files transfer on import, for instance to Papers.
  • What happens when you try with bibtex but _without_ the file box checked?
  • Ok, I made a stupid mistake –  I launched from a wrong Zotero Library (from which I had culled most pdf's earlier.

    However, the import problems described remains with the correct library. While all pdf files are now exported fine, they still dont import to Papers. Only the references are imported.

    Export to bibtex and import without files work fine.
  • I expect fully Endnote to have crappy support for importing from other reference managers, but it still seems like a problem resides with the Zotero export function, when the other reference managers also wont import.
  • edited June 6, 2017
    This is a thorny issue. The problem appears to be that at least Mendeley (which is the only one I can test with) will only import attachments from absolute paths. That means any import/export can only work on the same computer.
    Zotero's export uses relative paths (that's why it exports the files into the same folder as the export format). Admittedly, that's of little help if no other program imports that, but there is a real trade-off involved.

    At least in Mendeley, I _do_ get file import when _unchecking_ the file option in Bibtex in Zotero, because that has Zotero include absolute paths in the .bib file.

    What you can do and what I'd expect to work on all software (though who knows with Papers, which is hardly seeing any support anymore) is to replace the link to the file in the RIS (which is the easiest to work with) with an absolute paths using search and replace.
    So say you've put the export in the C:/user/Documents
    you'd do
    search: L1 - file/
    replace L1 - C:/user/Documents/file

    I'd like this to work better, but it's not easy -- not least because what other software does with file imports is a black box. There no debug output, let alone code, where I could get a sense of what they're doing.
  • Thanks for your detailed thoughts on this. I will try a file path replacement with a RIS export.
  • This worked like a charm. I tested on ReadCube.

    Maybe a solution would be to give users a choice to export for other reference managers (absolute path) or for use by other Zotero (relative path).
  • yeah, I think that we'll need to do just that in some way that doesn't overwhelm the amount of preferences on export.
Sign In or Register to comment.