Zotero 5: special char not filtered

edited May 31, 2017
Using "Retrieve information from PDF" from this paper: http://www.tandfonline.com/doi/abs/10.2747/1539-7216.50.2.197

Add a title with special char encoded: "The Chinese & lt;i>Hukou& lt;/i> System at 50".

They should be filtered out (they are from the Firefox Plugin)
  • To correctly print that title as published (with Hukou italicizes), they HTML tags are needed, so it appears that the Retrieve Metadata function is working correctly.
  • It's actually not showing in italic in Zotero but with <i>Hukou</i> . Anyway displaying strange char is a bug as 99% of the user don't get what it is and PDF file name will be ugly.

    So if we want to support HTML in title field, fine but it should be displayed correctly and have a way to edit. I do think it's overkill.

    Perhaps using simply * for italic and ** for bold would be a better option, but then you have to add \* when you want to print a *.

    Still for the moment filtering out special char seem the safe things to do.
  • Yeah, it's definitely a bug as is — the encoded braces won't (or at least shouldn't) make it italic in citeproc-js anyway. So this should be fixed to import as "<i>Hukou</i>". Obviously we'd ideally render that as HTML in Zotero itself, and that's the plan, but in the meantime showing basic HTML that produces proper citations is better than throwing away data.
  • (it looks like CrossRef is doing this right & it's our bug; I'll try to take a look)
  • Thanks. Ticket created.
Sign In or Register to comment.