Zotero 5.0 Bug: all content of note deleted when backspace + impossible to do Ctrl + Z

Sometimes when I paste a text into a note and press backspace to delete the last characters pasted, the whole content of the note disappear. This happens even thought the whole text isn't selected.

Some debug steps:
- After pasting, I move the cursor somewhere at the beginning of the note and then set it back to the end of the note and press backspace. The whole note is still deleted.
- The source code is normal.
- This happens on a new (empty) note and on existing note (which already had content before the paste)

This bug is even made worst by another unrelated bug : sometimes the Ctrl + Z doesn't work and the whole note is lost.
  • Me too. So I lost some notes. I think it's a bug.
  • What OS? Z-standalone or the FF-plugin? 4.x or 5-beta?

    FWIW I use notes extensively and do much cutting and pasting and moving of text. I cannot reproduce this with Z5-beta standalone on a Mac and Cmd-Z always works for me. I have the freedom to move the cursor throughout a note, perform various cuts and pastes, backspace to delete text at the end of a note (or only the final character). Whether the note is opened in a Zotero tab or in a separate window -- both are working fine. This must be related to something OS-specific.
  • For me, Windows 7 + Z 5.0 beta.
    Today, I tried to reproduce but failed on 5.0-beta.202+ddc9989.
    The error is inconsistent.
    Anyway I have met the error from time to time.

    I promise to make Debug ID when it occurs again.
  • Also on Windows 7 + Z 5.0 beta.
    The error is also inconsistent but I had it several times.
    I am not sure, but I think the Ctrl + Z bug happens when Zotero has just sync (somehow the tracking of the changes would be lost by the sync).
  • Yes! Ctrl Z just deleted an entire note in Zotero Standalone 5.0.18. Infuriating!
  • I am also still getting this bug. I lost several notes because of it. Please do something. I am on Windows 10 now and Zotero 5.0.20
  • edited October 10, 2017
    It again happened today, I couldn't send a report for it. This time, it happened on a note creates a couples of days ago, with more than 1000+ char and when I selected a sentence an press "delete".
    Ctrl+Z didn't work so the content was lost.
  • I am getting this bug more and more often these days. The text just disappears. Most of the time it's only a sentence, or just a bolded word that goes back to normal. But it is still problematic...
  • I just realized that this only happens when the document I'm working on was found through the search bar and when the list of documents gathered through the search still appears in the middle column (Zotero 5.0.24)
  • edited November 13, 2017
    This is a rare, intermittent problem for me but it has nothing to do with a search result (because I seldom use the search function). I’m using a Mac. Sometimes (far from frequently) when I backspace to delete a single character to the left, everything in the note vanashes. Same thing with the delete (right) key—characters to the left also are removed and are gone. Same thing if I place the cursor in the middle of a word and add a character to correct the spelling. I’m certain that nothing is highlighted. In my use case the notes are quite short usually less than 75 characters so this isn’t an issue limited to lengthy notes.

    At first, I thought it was related to clicking outside the text area (similar to what happens when editing an item on ORCID) but I know that this occurs when I stay within the lines and I tried to reproduce this by clicking outside and no loss resulted.
  • I am on Windows 10, last version of Zotero and I also have this bug. It's happening for a while now (several months). I have this bug on new and old notes, when doing a search or not, when hitting backspace or delete (and even CTRL+Z).

    Please do something!

  • edited February 3, 2018
    Does this happen for notes you type from scratch, or only notes with content you've pasted in from elsewhere?

    If you restore from the last automatic backup, are you able to reproduce it reliably in a given note? If so, can you first right-click, choose "Source code", and email the HTML to support@zotero.org with a link to this thread?
  • edited February 10, 2018
    I just had the bug: I copied some text at the end of a note (which already had some content), select the last word that I just copied, and press delete to delete this last word... and the whole content of the note was deleted (even if it wasn't selected).

    As you ask, I restored from last backup and reproduced all the steps above (in the same note) but that time, I didn't get the bug. I checked the source code, nothing is anormal, just a bunch of "p" tags and some links.

    Another time, instead of the whole content of the note being delete, Zotero bugs: the note is still there (with all its content) but all the items in the middle pane disappear and there is a message instead (I don't remember it but it's like "something is wrong, please restart").

    The bug also happens when I create a note from scratch and when I add "by hand" some content (so no weird HTML content being paste)
Sign In or Register to comment.