Parentheses turned to brackets in footnotes

Hi all,

I encountered a weird issue.

First the background: I just started writing my PhD thesis in chemistry and spent all day fiddling with citation styles. Unfortunately no chemistry journal uses notes as citation style, which I prefer for the ****load of citations you get in a regular thesis (typically 200+) rather than having 10 pages of bibliography attached to your thesis.
So I took the .csl of Angewandte Chemie International Edition and modified it. Basically I just declared its class to be "note", copied the bibliography layout to the citation and removed one line of text to prevent it from adding the citation-number in front of the actual citation.
It works splendidly and gives me a numerical type citation with footnotes. (Except for having only the blank number as in-text except for brackets. But I can live with that)

Now the issue: It arises when I put in multiple references for one citation (which is relatively common in chemistry). I put "a)", "b)" etc. as Prefixes and "; " as suffixes. While being correctly displayed in Zotero, in the document (Word 365) every other parenthesis turns out to be a bracket instead.
Picture: https://abload.de/img/issue28bud.jpg
To be honest, I have no idea of CSL, so I don't know if this could have been caused by my modifications of the style. (Although I don't really think so) Btw: If I put square or curved brackets in the first place, everything works.

Does anyone have any idea on that issue?
  • @fbennett any thoughts on this? I assume this is citeproc trying to be too clever?
  • Sure looks like it. I'll look at it this weekend.
  • @fbennett thanks for looking into it. Did you find any clues on how to solve the problem?

    Meanwhile I tried to find a fake parenthesis that just looks like a parenthesis but is not treated as one. The only things I could find were similar unicode brackets. However, all of the options are either offset or stand out too much from the rest of the text when put in the document. So this approach on a workaround seems not to work out.
  • Nothing yet. I'm swamped at work, won't be anything for the next couple of weeks, sorry.
  • I have a similar problem with a parenthesis being replaced by a square bracket. I am currently adapting the Universit√© libre de Bruxelles style (history) for the Universit√© de Sherbrooke. The macro to display urls works correctly for a bibliography and the parentheses are generated correctly.

    However, when called for a citation, the closing parenthesis after the date accessed is replaced by a square bracket.

    I can provide the csl if it will help.

    L. Robichaud
  • yes please do post the CSL to gist.github.com as a secret gist and link to it from here (you won't need to register on github).
  • Just a note to mention that another set of parentheses for editors of a collective work do not get changed to brackets.
  • edited August 11, 2017
    Put the brackets in the group and not at the beginning and end of the two text variables and it works. Like this:

    <macro name="url">
    <choose>
    <if variable="URL">
    <text variable="URL" prefix=" &lt;" suffix="&gt;. "/>
    <group delimiter=" " prefix="(" suffix=")">
    <text term="accessed" text-case="capitalize-first"/>
    <date form="text" variable="accessed"/>
    </group>
    </if>
    </choose>
    </macro>


    P.S.: It would be great to get the style onto the repository to share it will all your colleagues once you've finished making it. :)
  • Problem solved. Thank you.

    I will definitely place it on the repository if we don't find other unexpected behaviours over the next few weeks.
  • edited September 18, 2020
    Hi! Sorry to comment 3 years later ...

    I recently posted a related question here: https://forums.zotero.org/discussion/85030/parentheses-in-parentheses
    (And yes, I'm talking about the begin and end parentheses I write in the prefix and suffix field of the ZOTERO interface in Microsoft Word.)

    I now read through all this and as far as I understood

    1) the flip flop of parentheses and brackets is not something I can change in a citation style, this is the developers' business

    2) it might be difficult and lengthy to implement the flip flop behaviour for the editor prefix/suffix and for parentheses in the title.

    If both assumptions are correct, what is my option?

    Do a Search&Replace in the final word document, I guess.
    I was trying to use Word search with wildcards (Mustervergleich).
    My pattern should be:
    (left parenthesis + any characters + NO closing parenthesis ) + left parenthesis(

    I tried (\(*[!\)]\() and similar

    It does not work: the search results contain a right (closing) parenthesis.

    Any help would be greatly appreciated. Thank you!
Sign In or Register to comment.