1.0.0b4.r2.r1365 - Word template bugs

I'm running Windows XP SP2, Word 2003, Firefox and Zotero 1.0.0b4.r2.r1365.

I'm also using the Chicago (Author-Date) citation style.

When adding multiple references to different publications which share the same author and year, I'm encountering multiple bugs.

Firstly, the short author-date references don't seem to be working. Instead of being (Author 2007a) and (Author 2007b) they came up as (Author 2007) and (Author 2007b). This cannot be fixed by updating the fields as this results in an "Error! Bookmark not defined" message. However, the bibliography at the end of the document correct displays Author. 2007a. and Author. 2007b.

Secondly, if the date of an item has been changed since it was added (or Zotero was loaded, I can't work it out), the reference does not update, even if you have not inserted it yet. For example, say I have a reference in my library by Foo made in 2000. If I change the date to 2001 and then try to insert a reference, it still comes up as (Foo 2000). This is not fixed by closing and opening the document and trying again.

Thirdly, and finally for now, if you later remove short author-date references from the document and recreate the bibliography you are met with Run-time error '5941' - The requested member of the collection does not exist. It still works though.

Any clues for these, especially the first one?
  • edited April 11, 2007
    Is anyone else experiencing similar problems?
  • Are these issues not reproducible or is the Word plug in just not a high priority. I want to know whether it's worth converting all my references so far to Zotero ones but if these bugs won't be fixed soon it will be more trouble than it's worth.

  • I get slightly different but still incorrect behavior. References which should display as, for example, (Author 2005a) display as (Author 2005) when first cited. When cited subsequently, they do display as (Author 2005a). Sources that should cite as (Author 2005b) and so on have no problems. Can you confirm?
  • Thanks for getting back to me. I think I was mistaken and you are correct. No matter how many times something is cited or how much you reorder/remove your citations, it's always only the first instance of 2005a that is missing the a.

    The other problems are still the same and I've also noticed that with multiple authors, the alphabetised suffixes don't work at all. i.e. (Foo and Bar 2005) and (Foo and Bar 2005) instead of (Foo and Bar 2005a) and (Foo and Bar 2005b).
  • It doesn't even work with me. I get a runtime error, which I have to end, and then no citation in my document, only {Citation}. It won't insert a bibliography either. I get a runtime error I have to end as well. It used to work before I downloaded the latest Zotero update and the Word plugin update. I also get runtime errors when I try to use the "Set doc prefs" button. Please help! I am writing my dissertation...
  • I have the same problems as "ransomca", that is: I get a runtime error, which I have to end, and then no citation in my document, only {Citation}. It won't insert a bibliography either. I get a runtime error I have to end as well. I'm using the newest version of Zotero (as of 4/12/07), Mac OS X 10.4.9, Word 2004 v11.1.

  • edited April 12, 2007
    Just to be clear, you're both using 1.0.0b4.r2.r1365 and the Alpha 2 version of the Word plugin linked to from the documentation page?

    Does this happen with a new document, or only in an existing document? If a new document, please provide exact steps to reproduce the problem. If you have an existing document that this occurs in that you don't mind sharing, you can send it to support@zo.....org, and we'll take a look.

    Also, does the runtime error say anything else?
  • Dan,

    Thanks, Yes, I'm using 1.0.0b4.r2.r1365 and the Alpha 2 version of the Word plugin. I updated both of them yesterday.

    With a new document I get VBA "Runtime Error 5, invalid procedure call or argument". I get the same thing when inserting a bibliography or a citation in an existing document, too. For the new document, here's what I do:

    File: Project Gallery: My Templates: Zotero.dot.
    {in Zotero, select the ref I want to cite}
    Click the Word Zotero Toolbar Button for Insert Citation.
    "{Citation}" appears as does the runtime 5 dialog
    As that is happening firefox jumps in front of Word, and stays there. I switch back to Word to see the runtime 5 dialog.

    when I go into VBA, I see that this line is the offender:

    itemString = ActiveDocument.CustomDocumentProperties("ZoteroStyle").Value & ":" & ActiveDocument.CustomDocumentProperties("ZoteroUseEndnotes").Value & itemString

    which is inside "Function ZoteroRestoreSession()" Let me know if that helps. I'll forward Zotero Support my .doc file, too.

    Thanks for the quick response!

  • edited April 12, 2007
    Tim: Where did you install Zotero.dot? The .dot file should be in /Applications/Microsoft Office 2004/Office/Startup/Word.

    You shouldn't create a new document using Project Gallery: My Templates: Zotero.dot (and, in fact, it doesn't even appear there for me) or open the .dot file directly—you just create a new blank document and use the toolbar buttons to insert the citations...
  • edited April 12, 2007
    Any more news about the bugs I started this thread about? It could just be a quick and simple fix...
  • turkeyphant: We have a ticket open.
  • Okay, Thanks Dan. I just put the .dot in My Templates because I did'nt know where to put it, and I guess the installer didn't move it automatically (?). Anyway I moved it, and restarted Word, and the single, multiple, and bibliography inserts work! Thanks so much! You Zotero guys are my Heros!

  • edited April 12, 2007
    There's no installer yet, just the documentation page. We're planning to have platform-specific installers by the time 1.0 Final is out (by which time we'll hopefully also have a beta version of the plugin).
  • My Zotero.dot is in the startup directory in my user Application Data folder. I just re-downloaded Zotero and the Word plugin yesterday from the above mentioned links. The document I was working with was not a new document and I'm not sure if it had previously inserted Zotero citations or if they were from EndNote. I will try both ways to see where the problem lies.
  • Okay, with a brand new document, it works fine. If I try to add a citation to a document that I created using Zotero before, I get the error. I don't know anything about Visual Basic so I can't really go in and see what the problem means. Hope this helps. If you want me to send a sample document I can. Where do I send it?
  • Callista: Did you create the problematic document as a new blank document, or is there a chance you created it through Zotero.dot, as Tim did? If I open Zotero.dot directly and create a new document that way, I get the Runtime Error 5. Is that the error you're getting?

    Can you copy the text from that document into a new one and use that?
  • turkeyphant: We have a ticket open.

    We're planning to have platform-specific installers by the time 1.0 Final is out (by which time we'll hopefully also have a beta version of the plugin).

    Okay, cool. Is the timescale for a fix for this sometime far in the future then? Only I have a paper I need to submit soon and I want to know whether this will be sorted in time for it or not. If not, it's not a big deal but I don't want to start converting all my references to Zotero if it won't be fixed before then...

  • Hi Dan,
    No, I didn't use Zotero.dot to make a new document. I made it a few weeks ago with just a normal Word file, using the Zotero buttons. It worked fine before. I will try to copy and paste into a new file to see if that helps, and let you know.
  • Okay, I copied and pasted the text into a new document, and tried to insert the bibliography. At first I got an error but that was because Zotero had gone and inserted an extra ( before all my in-text citations (because I had manually fixed them after the last version's bug). So then I had to go and manually remove the extra ones, and a search-and-replace did not work to remove them. After I did all that, I was able to insert the bibliography no problem. I could also insert citations. It seems to work fine now. But I'll have to copy and paste all my documents into new documents and then manually replace all the ( I had manually inserted before in order for it to work.
Sign In or Register to comment.