"Safer" Track Changes practices in Word?

I am aware that Track Changes and Zotero do not play well together, and the best advice is not to use Track Changes at all. However. If one were to be forced to use Track Changes (especially with a Word document that is passed around and edited by multiple Zotero users) are there any "safer" practices that might let you avoid the biggest headaches? For example, turning off Track Changes before making any edits that might affect a citation, and then turning it back on again when you're done?
  • If you don't use Track Changes when adding a citation, that's certainly safest, but in most cases, track changes is fine. The problems are relatively rare and then almost always fixed by accepting all changes.

    The one thing you don't want to do is manually edit a citation in Word with track changes active.
  • Thanks! Can you clarify what you mean by manually editing the citation in Word? Like, would that include deleting a citation using backspace, or copy-pasting chunks of text that include citations? Or do you mean actually typing within the greyed-out citation text?
  • the latter, typing within the greyed out citation text.
  • Thanks again!
  • the problem I am having even with the new zotero and word 2016, is that as soon as I open the document I get a bunch of "unknown field code changed" and also "user name formatted: English or french or whatever. Which is really strange since I am only working on English documents. I also get the problem that when accepting changes that do not involve citations, the field codes get expended by word https://forums.zotero.org/discussion/35140/word-accept-changes-converts-to-field-code. As the new version addressed any of these issues?or what is the solution to avoid these problems, particularly the first one I have mentioned.
  • With the field codes expanding under Tracked Changes, just click Accept twice for each one. Word is just showing you which changes are being made in the underlying field codes. The field codes should disappear again after you accept twice (once deleting the old field codes, once for deleting the new ones).

    Word's language support seems to not play well with any text in fields (whether from Zotero, another plugin, or even Word itself). In any even, the language a text is set to only matters for spell-checking, so you can safely just accept or reject these language changes.
  • Is there a way to accept all changes related to this "unknown field code changed"?
  • It's been over a year since the last comment. No resolution? This is SUCH a pain.
  • Tracked change field behaviour is in the hands of Microsoft, not Zotero, so we can do little to help with this.
  • Easy fix for me. Turn off track changes, change the citation style, then change back to the desired style. You should now be able to accept the changes without the encoding coming up.
Sign In or Register to comment.