Chrome connector error -- Google Scholar

I cannot use the "save to Zotero" address bar icon in Google Scholar in Chrome; I always get a message "an error occurred while saving this item". When I go to the Zotero Connector in extensions and click "options", I see a a "report errors" section with many instances of the following:

[JavaScript Error: "getTranslators: detection is already running" {file: "chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/zotero/translation/translate.js" line: 1056}]

When I click the "Report error" below that, I get a report number 1710145344.

Can you help?

  • Is this with Zotero open?

    Can you provide a Debug ID (different from a Report ID) from the connector for a save attempt?
  • edited April 14, 2017
    It's been happening regardless of whether Zotero is open or closed.

    I don't know how to get a Debug ID for this problem. There's none on the error message on the Scholar page. The Connector Options page says "Please post a message to the Zotero forums with this report ID". The current one is 356890057
  • OK, got it. The debug ID is D1300491611
  • That's from Zotero, not from the connector.
  • OK, trying again: debug ID D1830073709
  • (4)(+0053829): Translate: Parsing code for Google Scholar (57a00950-f0d1-4b41-b6ba-44ff0fc30289, 2016-08-22 11:25:00)

    (3)(+0000003): Translate: Beginning translation with Google Scholar

    (2)(+0000004): Translate: Translation using Google Scholar failed:
    string => Error: Translator called select items with no items
    stack => Error: Translator called select items with no items
    at Object.selectItems (chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/zotero/translation/translate.js:457:11)
    The page you're trying works for me. Does this still happen if you disable all your other Chrome extensions?

    You can also try resetting translators in both Zotero (in the Advanced → Files and Folders pane of the preferences) and the connector, though that doesn't seem like the problem here.
  • Aha! Solved. I had the Paperpile extension on for working with Google Docs, and not surprisingly, it conflicts with Zotero, at least on Google Scholar. Thanks.

    (I do wish Zotero worked better with Google Docs, though.)
  • I've never looked at the Paperpile extension, but I can't think of any reason that should be the case. This is reproducible if you then re-enable it?
  • Yes, it's a clear 1:1 correspondence: disable the Paperpile extension, zotero works; re-enable Paperpile, zotero fails (on Google Scholar).
Sign In or Register to comment.