Cambridge core - proxy puts hyphens in the URL, breaks translator?

I can't add anything from Cambridge Core to Zotero using the save button. I gather that there's a problem with my university's proxy adding hyphens to the URL, as explained in this post:

I've reset my translators and updated them to make sure I'm not missing a new Cambridge translator, so I'm guessing that my Uni's proxy server is doing something unique.

In the post above the possibility of setting proxy settings manually is discussed - but for the life of me I can't find any proxy settings, either in Zotero or in Firefox. Is there something I'm missing?

BTW, I'm using Zotero SA; Firefox 52.0.2; Win10

  • Are you using the Beta Connector for Firefox? That will probably fix the problem, although we have not tested whether the connector fixes https proxy issues with 4.0. If it does not you'll have to switch to Zotero 5.0 Beta.
  • edited April 14, 2017
    Hi adomasven, yep, that seems to work! Zotero SA4 now recognizes the hyphenated URLs and I can save from Cambridge Core. Thanks for that - I hadn't thought about trying the beta connector with SA4 ...

    Thanks for the quick response!
Sign In or Register to comment.